Download

First time deploying - tests time out

So I’m trying to deploy Tappy Chicken. I’ve managed to work through the provisioning and identities, but now I’m getting a timeout when running tests before launch.

I’m building on a 2011 model Macbook Pro that only has 4gb of ram, so I figure things might be running a bit slowly, but the rest of the build is relatively fast.

I’m deploying it to an iPhone 6 Plus.

Any ideas? The exact message is:

Test target UE4CmdLineRun encountered an error (Canceling tests due to timeout in Waiting for test process to check in…

Solved. In case anyone else gets this, here’s what happened:

Some guide I read somewhere (UE4 or Apple docs) said to make an ad-hoc cert. This is dead wrong. Make a development cert or it won’t work. After that and with everything else configured correctly it worked.

So, time-out test problem = wrong cert. Don’t use a distribution cert.

I have one more noob question - while I was looking around for answers to iOS build questions I found a page that talked about initiating the iOS build on a Mac from a Windows PC and having it take place automatically. I can’t for the life of me find it again and my history is about a thousand items long today - does anyone know of a resource to help me set this up?