First Person view missing arms and weapon

I know this is all my fault as I think I disabled it a while back during level creation but now I want it back and for the life of me can’t find where… Basically all meshes for weapon and arms are there and are visible in first person character blueprints but not in the level.

Please assist! :slight_smile:

Hey StayFirst,

From what I understand regarding your question, you’re wanting to have the arms and weapons show up in your game for you as well as other players, correct? If you wish to do this, please go into the Character blueprint, look under the Viewport tab and highlight the arms/weapon of your character. Once you’ve done that, please then look over to the right-side (default settings) of the Editor and under the Details panel, scroll down to the Rendering section and put a check box beside ‘Visible’.

Once you’ve done that, compile and save the Character blueprint and then play within the editor. You should see the arms and weapon appear when you’re in game.

Let me know if you have any other questions, have a wonderful day!! :slight_smile:

Thanks for the quick response Samantha!
I did however find this setting already and that’s not it. It is checked and I can see the hands and weapon in the viewport but not in level…
Also “Hidden in game” checkbox right beside it is unchecked.
There must be something else :confused:

Hey StayFirst,

Do you have ‘Owner No See’ under the ‘Rendering’ drop-down menu checked? This menu is within the ‘Details’ panel under the character blueprint. You’ll find the option within the viewport tab. If so, that would be why you wouldn’t see the hands/weapon as well. Could you take a picture of your settings?

Cheers!

Hey,

Could you press the down arrow that’s under the Rendering section? That’s where the ‘Owner No See’ is located.

Thanks!

Oh my god that’s it! :slight_smile:

Thank you very much! I knew I did it somehow! :smiley:

You’re very welcome. :slight_smile:

If you have any additional questions, please do not hesitate to post on AnswerHub! Enjoy your weekend!