First Person Movement in Scifi Bunk project

Hi, i try a space project. I used Scifi Bunk project as template and it work great. The character moves in space as it should be butI am trying to add a new level (Map) with first person player in a planet. The movement still works as in space. I mean when i press movement buttons the character moves as in space and had no gravity. I want the palyer moves as in the earth in this map. I created the map level from scrath but no chance. How can i use fps movements in this map? thanks…

read the docs Game Mode and Game State | Unreal Engine Documentation

could you please be more specisific? i tried assigning a new game mode or game state but same. the character still moves as in space.

the docs will tell you how to setup character movement, customize a pawn, create new game modes, setup input and about 300 thousand other basic things to get your game working.

really mr. super mind? could you understand what you read? as i wrote above customizing, changing or even creating new game mode setup doesnt solve the issue? i played movement and gravity values but no chance. so if you are not kind to help, please do not geek out.

my past 400 posts or so are literately me just helping people. so here you come along with this super basic thing you can’t work out, i show you where you can learn to setup characters and all you can do is insult me? I’m happy to help people but they need to try to help themselves as well.

scifi bunk has the gravity turned off, even though its just using the spectator pawn that isn’t affected by gravity anyway. did you turn it back on? should be 9.8m/s or -980
have you built a custom character? have you customized one of the default ones?

seems to be working fine to me:

sorry for my rude reaction but as you said it is a very basic thing and i tried a lot of things to solve this issue but no chance. im not a pro but i have a brief knowledge about how the game mode or characters used. while im starting the project i thought it will be very easy but i am working on this issue for days. as i said above i changed to gravity values but it still moves very slow as in space. i am adding a video. as you will see on the video the character drops very slowly. it is a first person character not a spectator pawn. i migrated it from unreals default fps project (i have already tried creating the first person character from scratch, migrating from some other projects). the game mode is also fps game mode (i have already tried creating from scratch and migrating some other projects, too)



i recreated scifi bunk project from library, created new level and now it magically works. it is wierd. i still dont know what was the issue. thanks for the comments and help.

glad you got it fixed :slight_smile: off the top of my head, it might have been the config file was set to read only, sometimes windows does that and you have to go to the folder and set the permissions back to read and write