Download

First Person issues

I have replaced the First Person template arms with my own mesh that has animations and everything on it. I got everything to work and it all works great except for this one this i cannot seem to figure out. And the is the Camera When i move left or right the arms move with the camera just fine but if i try to look up or down only the camera moves. I have the camera attached to the mesh in the components tab and i have not touched the blueprint part of the camera movement. Does anyone know how to fix this?

Add your weapon mesh in the component tab, not in the Defaults

I tried to do that just now and it did not fix it ;/

Hmm, strange :slight_smile:

Could you probably post your steps so that I can recreate your problem (I had the problem with the Z axis and I solved it with the solution that I posted above)

My steps (the first part of the video is the right way how to do it -> I do it without a animbp. You can just assign it under animbp tab):

https://youtube.com/watch?v=i_yDm4QJal0

First i imported my arms
Second I imported the animations for my arms
Third I made a Blendscale 1D
4th I made a Animation Blueprint
5th I went to Mycharacter/edit then i defaults i changed the FPP_Hero to my Hands
6th i went into components and added the animation blueprint to my Hands

Edit: I tried it like you did it in the first part of the video and it still did not work.

I think you mean blendspace 1d -> where/how do you use it in your bp?

Is it possible for you to send me your assets so that I can take a look at it? Because I think you have disabled or accidentally removed/edited something :slight_smile:

It is used to make a blend between animations idle ----> walk -----> run i doubt it would have anything to do with this problem.
And sorry i would like to keep my assets.

I had a similar problem, fixed it by realizing that the arms needed to be a child to the camera component in the MyCharacter>Components view. Is that the case for you?

Yes that fixed it. But is that the only way to fix it? Because now most of the blueprints i have are messed up now because of that.

Does anyone know if this is the only way to make the Z axis work?

Ok ive been trying for a few hours now and nothing seems to work.When i move my camera up or down the mesh does not follow. Does anyone knows whats going on?

I fixed this by attaching my skeletal mesh to the first person camera. And then to fix the blueprint issues i had i used “cast” and cast them over to my skeletal mesh instead of the default mesh.