Download

First Person - broken

Add New–>Feature or Content Pack–>First Person

The First Person doesn’t shoot the projectile (ammo)

As far as I know, this was usually just a sphere. However, the feature pack seems to be broken since a while.
Does anybody know where to download one that works, including the ammo and the projectiles?
Or how to fix it?

Would be nice if epic could fix it within the Feature content pack!!

thanks

It’s not broken since nothing is missing or not working. You might need a projectile to spawn, but others might not.

In any case, you have 2 possibilities:

  • create a projectile and setup the character, which should take just a couple of minutes;
  • copy both the projectile and the character BPs from a first person project to your current project.

Its far more likely that you are missing the input.

I can assure you. If you are trying to load the FirstPerson from the Addon - you will see it’s not working as it should.

The projectile is missing for sure and I appreciate your input and info. But here is the catch. If I would know how to add the projectile and to setup the character, I would have not posting here.
That’s my problem.

If you start a new blank project and add the First Person - you will have the same problem.
Any help - tutorial, etc. in fixing it - super awesome. Appreciate it!

did you even open the character blueprint and compile it?
if you haven’t, do so.
if you have, plase share a screenshot of the BP without errors.

Template vs “New–>Feature or Content Pack–>First Person”:

vs

again… that’s what I am using… I tried the features content pack and the C++ - non if them are working. so what now?
can somebody give a clear answer?

So, just to clarify, this happens not only if you start with a BLANK PROJECT (where is nothing and then you add the first person afterwards) but also if you start with the FIRST PERSON TEMPLATE PROJECT (where you ready to go from the start). Right?
If this is true, then there must be a problem with your engine installation (which is a very weird issue). I never heard of a problem like this.

Bernhard if you look closely at the pictures EvilCleric posted, when you make a FPS project it shoots a sphere object, if you add the FPS feature to any kind of project its an “instant hit”, in other words, a hitscan weapon. When you open up the PlayerCharacter blueprint you’ll see that it does a line trace, not spawn a sphere. Its working as intended.

yes, thank you. that all makes sense. And yes, EvilCleric you got this right. Even when I was launching the new Project file it didn’t work. But I got this figured out now. Somehow my Unreal Installation was broken. I verified and got the orginal built and now this works fine.

Last but not least. When I try to migrate the First Person Character Setup from the First Person Template project. Ohhh boy… it’s not working.
Any ideas what I could miss when migrating this thing?

What exactly are you trying to migrate and to where? A blank project?

All I want… is that I can migrate the FirstPerson with the Shooting Ball into any new Project I create. That’s it. Nothing else I want. But no matter what I tried so far. Nothing works. I thought if I am going to start a new project from scratch and migrate the FirstPerson with the shooting ball profile to a new project - and if I swap out the Game Mode to the FirstPerson it will work.

But it doesn’t. ■■■■.

Steps:

  1. BLANK PROJECT - X
  2. FIRST PERSON TEMPLATE PROJECT - Y
  3. In X, Add New -> Feature or Content Pack -> First Person
  4. Go to Y\Content\FirstPersonBP\Blueprints
  5. Copy FirstPersonCharacter.uasset and FirstPersonProjectile.uasset
  6. Go to X\Content\FirstPersonBP\Blueprints
  7. Paste files replacing FirstPersonCharacter.uasset

Hello, I realize this is over a year old but I think it’s still relevant for beginners. I was wondering why they changed the First Person template so I searched and found this thread.

I can confirm that for v4.26.2 and v4.27.0 this is still a thing. If you create a project from the template it will have the projectile character and if you add the template to an existing project you will get the hitscan character.

This seems like a mistake to me but it is not a problem with your engine installation. I’m guessing they decided to change the template to hitscan but didn’t finish the job so there are actually two sets of files.

I think what would be ideal is to have both characters included in the template. It would be very simple for Epic to do this. Two maps, two game modes, two characters. If anyone needs help getting both of these characters into one project reply here and I will help. It requires some renaming to get it to work.