First person Blueprint Character will not move, no matter what

I can confirm that the default land movement mode is walking, and gravity is set to 1. However, when I try to print “is move input ignored” to the screen, nothing prints, and watching the blueprint while the game is running shows that nothing is firing, not even straight from the Event Tick or Event BeginPlay.

The mouse inputs work, and I can look around. However, any movement of the actual player never happens, including falling, and using WASD to move. I have confirmed that my axis inputs are coming through as the correct values, and the add movement input node is in fact triggering. However, this still does not move the player.

I have also confirmed that the “LockWASD” variable is set to false by default, and in the placed instance of the player. I’ve even completely removed the LockWASD branch and just hooked it up normally, and still the character was suspended in the air unable to move.

Also, as far as I am aware, the walking worked perfectly fine before I last closed the file. Other files with this same bit of movement code are unaffected by whatever this is.

Check in the movement component if the default land movement is Walking. Check if gravity is not 0. Also check if move input isn’t ignored.

You’ve most likely disabled tick. Print on tick what the movement mode is for the Character Movement component. Also if you posted a gif or a video that might help.

Unless I interpreted what you said wrong, printing the movement mode does not print anything, the same thing from before happens. How can I enable tick?

Enable tick in class defaults.

At this point I think it would be very useful if you made a short video of how you start playing and the BP itself while you’re playing.

That box is already enabled.

I can’t. OBS decides to capture the tooltips and only the tooltips no matter what I do.

If you have Nvidia GPU you can use Shadowplay: ShadowPlay | Record & Capture Your PC Game Moments

For AMD:

Nevermind, I got it to work using a regular display capture instead of window capture.
Here’s a video showing what I’m doing. I’ve added a bit of blueprint that prints the key I’m pressing so it’s easier to see. I made sure to turn off consume input.
Movement not working - YouTube

I’m on my phone right now so I can only provide limited help, but my suggestion would be to add the First Person Bp to your project and then take a look at how they handle the input there.
It looks like this isn’t setup correctly.

Hmm… If you want you can send me your project. I can have a look. Marcis