Download

First person animation issue.

Hey, I’m trying to create a first person weapon animation and I’m having trouble getting the animations in maya match what is in the game.

To be more specific I want to animate a weapon that has multiple parts, and I need to add that weapon to the scene as well as the HeroFPP skeleton and the animation I’d like to modify. I’m using the character from the FPS shooter example in this case.

So I open up the skeleton of the character in maya, I import the animation.fbx (in this case the idle animation). Everything then snaps into place and I import my rigged weapon. I then point constrain the weapon root to the b_RightWeapon bone and the weapon snaps up to his hand.

The problem is though that I’ve already tried doing this in the game and there it seems the weapon attach point is at a different position than what I get if I export the animation and skeleton from the game to Maya.

So this is how the weapon sits in maya.
MayaWep.JPG

And this is the attach point in-game.
c66f23a3f54735e30ac0644d08ff0a129cbf36cf.jpeg

And this is where it ends up when playing the game using the default animations. As you can see it differs from how it is placed in Maya using the same animation imported from the game.
UnrealWep2.JPG

But I can’t seem to find what’s causing the transformation of the weapon attach bone in-game. If it was in the animation it would follow into Maya when I import that animation. I tried looking through the attach points in the game to see if they are translated somewhere but it all looks zeroed to me. Looking at that weapon attach point in different states of the idle animation it’s always set to zero as it should be.

Anyone know what I might be doing wrong here?