Download

First archviz work

Hello, after struggling and learning all these last days I think I could share my first ‘serious’ level.

Its still an empty apartment, just volumes and a few textures (And one random IES light over the concrete wall). Any advice or recomendations are always welcomed.

618376b7f23e9f633e985b6cf0d70512ac2bafcf.jpeg
17908c957eb5b1d8cd5214d3604ee99ce0accc05.jpeg
4012b83670f83f59c6cdc9108a799e45b8880634.jpeg

I have a few questions though :

  • Its just me, or is UE4 in a different human scale? I made all the map in AutoCAD first and it seems smaller or my character is too tall. I had to resize everything up to ~1.4.
  • How can I correctly change the sky to a neutral white? (Like almost every archviz demo I have seen) Im using BP_Sky_Shere by default.
  • Which is the correct option for a shiny floor? I want reflections from the windows but after many tries I couldnt find it.
  1. the UE4 uses cm. So 1cm=1uu
  2. the easiest way it to create a unlit white material which you assign to a sky sphere :slight_smile:
  3. I personally would use metallic + roughness in the material -> take a look at the floor/wood materials from the starter content

The scene looks really good! :smiley:

Thank you fighter5347 I’m really enjoying UE.
I followed your advices and I’m managing materials much better now.


I dont want to abuse but, can you point me to a tutorial or where to learn in how to get rid of the crosshair, shooting or modifying the walk speed etc (like in RealisticRendering project for example)

Looks nice especially all the lighting in the scene, only thing i don’t like is concrete wall, it seems like the normal map renders incorrectly my guess is that you forgot to invert green channel on import

Thanks Piroman, I didnt know about this issue. I see you can change this inside UE4 instead of going back to PS.
Here is how it looks now with a spot light over it.

Do I always have to flip the green channel? Or is it just in some textures?

Unfortuantely there are no tutorials around that shows how to do this, but there are several ways depending on the template that you use :slight_smile: -> then I can give you a detailed explanation

When you just want to have a flying camera, you just have to set the gamemode to “GameMode”

I’m using the FPS template. I already disabled the blue dummy arms but I dont know which step goes next.
My goal is to play the scene like a videogame just walking around.

  1. delete the arms in the component tab
  2. delete the part with the “spawn projectile” in the event graph
  3. double click onto the “mygame” gamemode - change the “HUD Class” to “HUD”

You can change the walk speed in the character bp under the defaults tab -> max walk speed :slight_smile:

Thank you again, everything done and tested just fine. :smiley:

Just one more thing I forgot, where can I change the fov inside the game? I already know in the viewport.

I followed this](https://docs.unrealengine.com/latest/INT/Gameplay/HowTo/UsingCameras/Blueprints/index.html) tutorial, the Using a Static Camera part but somehow I cant move my character after creating the blueprints.

You could do it like that:
76cf64822b0a45d28fbaf8d0182f530a37026461.jpeg

Just add an event in your character bp - add the fps camera - add the “set fov” node - choose a value

Edit*
Done, I think I still need more training in BP. :o

I wanted the fov value to become avaiable without having to push a button before.

Here we go :wink:

942562a8b8b927563858456df36440acc6838b8b.jpeg

Finally done! This made it perfectly, thank you for your patience :slight_smile:

b3a1aa987be172fbf73d058904d2fefc2a411629.jpeg

No problem :wink:

Just a short side note -> when you always want to use the same FOV settings, you could also change it in the camera settings (click onto the camera in the component tab - search for “field” - change it) -> I thought you want to change it during the game (then you have to use the upper setup) ^^

After many tries and some free time too I think I’ll start another project for continue to learning UE.
I leave my latest screenshots here. There are things I’d like to pulish more but I think its enough for now. Feel free to give any advice, tip or questions.




Looks incredible! Great execution on lighting and materials. My one piece of advice is to tone down the chromatic aberration and film grain. The grain especially goes a little beyond realism and into the territory of being distracting.

Thankyou StephaBon, I was trying the PostProcessVolume options and you know what happens when you have a new toy :smiley:
Some people told me too decrease those two things too, they seem more like an imperfection.

I played with saturation/contrast/etc instead and I think I’ll start another new project for more practice.

9eafa4427b4d42855bef891cb9cacaea034f31c2.jpeg

I wish the images were sharper, could you set the images to a higher resolution?

Nice work! Always good to have another Autocad to UE4 user :slight_smile:
Can I ask how you are getting it from Autocad to UE4? or Did you just create the 2d lines in Autocad as a base?

Is there a option inside PostProcessVolume for sharpening the view? I’d like to treat them in PS as least as possible.
They are just plain screenshots from the viewport as Im not planning to make any videos, just testing a simple walking through the scene.

Hi QBert,
I like to work with AutoCad from the very beginning, starting from 2d and then making simple 3d volumes over polylines.
Then I use 3dsmax for more complex things. I import the .dwg just straight, no changes. If I remember correctly, in earlier AutoCad versions you had to export the file in .3ds format.
Finally is just exporting to .fbx and thats all.