Firebase analytics doesn't work while using sqlite plugin UE5, iOS

I’m having problems integrating firebase analytics into my iOS app on UE 5.2. I found that the issue occurs when I have the built in sqlite plugin enabled. It causes issues with sqlite failing to add analytic events to the queue. I also tried the GameAnalytics plugin and it has the same issue that resolves when I disable the plugin. Unfortunately I cannot disable the plugin as its needed by AppleARKit which I cannot remove. GameAnalytics offers a work around for sqlite conflicts but I tried it and it didn’t work (Unreal - GameAnalytics Documentation). I’m looking to use either analytics solution if there is a possible fix.

Did you solve the problem?

I’m building engine from source (5.4) and I found that the Firebase and GameAnalytics can’t initialize the Sqlite. Or something wrong with the calls to sqlite from both libraries. It happens on iOS. I tried to update Sqlite locally, but no luck.

Firebase is saying

Database operation "validate database" failed with sqlite code 10 and error message "disk I/O error

GameAnalytics just can’t startup in its constructor.

I put breakpoints into sqlite create database function and it seems to creates it correctly, but then something fails in the next calls to sqlite.

Did anyone figure it out?