FInterp/Vinterp not working properly?

I apologize if this is a beginner question, but I’ve been going at this for a while now and I can’t seem to figure it out.

After getting some constant problems I eventually put together a simple script in the level blueprint that should print an interpolation of 1-10 with a speed of 1 (however I’ve tried everything from like 0.0001 to 10), and all it seems to do is jitter at around 1.12. I get the same problem with VInterp, however RInterp has worked fine for me multiple times.

Here’s the script:
And the result:
Any idea what I’m doing wrong/what’s going on? Thanks to anyone that can help.

You should be storing the result of the FInterp To and then using that as the Current Value

Or you should be storing the current time, adding Delta Seconds to that time, and using that new value as Delta Time.

Right now you’re repeating the same operation and you get varied results depending on how long that current frame took to render. If your input to Delta Time increases over time or your Current Value increases over time, you will see the result you are looking for.

1 Like

AHHH Thank you. That makes complete sense, I really appreciate your help - I don’t know why I didn’t get that sooner. Everything works now, thanks to you.