Download

Finding the drain on FPS, How?

So I have been optimizing my scene to work on tablets, but I am having a hard time finding what is causing slow FPS on Windows Surface Book. I average 70 FPS on my workstation (single level), but building to the Windows Surface, it drops to like 5 FPS. My space is just a small hotel room.

Things that I have tried:

Changed Settings > Engine Scalability Settings > (Mixture of Lows and Mediums).
Material Quality levels to “Low”.
I have 4 textures that are 1024x1024, 18 textures are 512x512, and 6 textures that are lower. I also have a video being played as a media file and its 8mbs. But I do not think that is the problem.
I do have some chrome materials being used, but their quality should have been reduced with the Scalability setting.
The worst item I believe is a sound file that plays music and its 25mb wav file. I can reduce the quality on this if necessary, but not sure if this is the problem.

Any suggestions on what I can do to improve playback on a Surface Book? Or at least for me to test what the issue might be?

Try reading these and using the Profiler.

are you using blueprints? if so make sure you dont have an Event Tick running many things… it can slow the engine down to a slide show

Thanks for the link ZacD,

Alpha. No, I made sure my event ticks were empty! Thanks for the advice though!

You can always try exporting your soundtrack to an mp3, atleast that is a significantly lower size since .wav files are lossless.

If MP3: if you exported the soundtrack with a bitrate of anything higher than 320kbps I’d recommend going lower (try 128kbps first, if success, work your way up) . It might just be that the Surface Book (or its soundcard) can’t handle higher bitrates.
I’d also recommend using a 44.100khz sample rate at first, if this fails, try going for a 32.000khz sample rate.