Download

Final render in sequencer - blueprint animation - collision on capsule causing problems

Using sequencer, I have a blueprint with a character mesh and an animation of it running up a hill. This animation is not root motion so the skeletal mesh goes way outside the capsule which apparently is still bound to the physics at its location. I’ve set a transform on the capsule to move the mesh uphill, and it looks fine in viewport but on final render it doesn’t work.

Is there any collision settings can I set the capsule to or the mesh to that will allow me to just put the mesh where I want it using a transform?

How does the final render looked like? I supposed that it captured the movement up hill but not the transform part? did you key in the transform for the sequencer or have sequencer trigger the blueprint custom event to move the transform?

Hey thanks for the reply.

On final render the mesh repeatedly falls through the hill…I’m keying the transform directly in sequencer.

So what appears to be happening is the capsule is being raised by my transform directly in sequencer to raise the mesh up the hill, but the final render is applying physics to the capsule which causes it to fall down after each transform. Since my mesh is far away from the capsule it keeps falling inside of the hill.

if you dont need the physic for the final render, just turn it off.

I’m unaware of a setting to do this. I always thought you had to turn on simulate physics. I did turn off gravity which didn’t help. My workaround for the time being is putting the skeletal mesh in the scene without the blueprint and then applying all the attachments to it in sequencer and and then applying the animation.

In the character BP, check skeletal mesh component. Uncheck the simulate physics.

Physics are required for ragdoll, falling, ponytail… things that are required to be simulated in the game world.

If the alternative method works for you, just use what works best for your situation.