FilterArray + Array with non-instantiated values

Please see: Access Violation when filtering array - Programming & Scripting - Unreal Engine Forums

If it is indeed intended for this Node to crash when checking an array with only NULL values (non-instantiated blueprint references) then it may work as intended. But it’s behavior is weird and no compile-time error. To me it feels as if it would require either a compile-time error or it should be made compatible to work with NULL-values. Because not setting it’s class (because we want to check for NULL/None) and then using an ‘input-array’ that has not a single instantiated blueprint leads to an instant crash.

Hi ,

A crash is never intended functionality.

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • Does adding an IsValid check before the array prevent the crash from occurring?
  • What steps can I take to reproduce this on my end?

Yesterday it kept crashing and today the same code in the same project does not crash… The only change is a of my PC. Also I could not reproduce it in a clean project.

The problem with like 80% of the bugs that I encounter with blueprints is that they are often temporarily, mostly solved by an UE4 or VS restart and are often caused by ‘desynchs between the blueprints and actual code’ and actions like changing parameter types/names in the headerfiles in VS (even after compiling and restarting UE4) will cause weird bugs that are temporarily and can not be reproduced later without making a lot of changes again.

Or for example (I had this a few times this week) I change a blueprint-function (change it’s input parameters). Then UE4-editor crashes upon compiling. After starting UE4 again I notice that the function compiled properly but the other blueprints are still using the old function with the old parameters. Deleting those nodes and putting down a fresh node to the function call will still use the old-function parameters (that no longer exists!)… ‘Desynch bugs’ like this happen to me nearly on a daily basis and are not always solved by just restarting and recompiling everything but may fix itself through unknown actions. I’m used to it. But sometimes I fear they cause other temporal-side-effects like this one and they are extremely hard to reproduce.

Or sometimes UE4 allows me to do silly stuff like accidentally connecting an array that directly derives from Object into a node like FilterArray (that only allows Actor-arrays) and then boom the editor obviously crashes and then you pray nothing corrupts.

I’m posting this as an answer because I can not reproduce it once again and just uploading an older version of the entire project takes too long :(.