Filename.generated.h file not found error Xcode

I have been working on a demo UE4 project for a month and all of a sudden I keep getting this generated.h file not found error that I can’t seem to fix.

I have a class LoginPlayerController.h and .cpp, the final include for LoginPlayerController.h is

#include LoginPlayerController.generated.h

This class has existed for weeks in my project and been compiling and working fine but I added some new functionality to it recently.

Now everytime I try to compile I am getting a shell script invocation error that says LoginPlayerController.generated.h file not found in xcode. I have tried nuking the intermediate directory and regenerating/rebuilding everything and still the same issue. I can see the LoginPlayerController.generated.h exists in the directory with all of the other generated files: /Intermediate/Build/Mac/UE4Editor/Inc/MyProject/

What is going on here? I can’t seem to find any info online as to why this is happening or why it only randomly started happening after a month in project development.

To clarify the include has quotes I just misstyped on my post.

#include "LoginPlayerController.generated.h"