File association with .uproject broken

I’ve unsinstall and reinstall unreal and the association for .uprojec file no longer exist for windows.
I can associate manualy with unreal editor, but I’ve notthe tools to generate à visual studio project.

I’ve tried 3 time to clrear and install again, same result

Someone have a solution ?

And I dont find the .bat to generate manualy th visual studio project.

1 Like

Hey -

Does the project show up in the project brower? Can you try right clicking on the .uproject and selecting Generate Visual Studio project files? If this doesn’t help, can you provide more information about the exact issue you’re having?

Hi , thank for your answer.

The projects are visible in the project browser.
Double left clik dont run the project, because .uproject extension is not associated.

If I do myself the association in windows explorer, the project can be run in windows explorer and in the project browser. But I dont have the “Generate Visual studio project file” when I right click. Not in the windows explorer and not in the project browser.

If I make a new project with C++ pattern, the visual studio project is done and it is ok. So Visual Studio and the link between Unreal engine are ok.

The only trouble is, for an existant project, I can’t generate the visual studio file because I’ve no command to do that. All the rest seem’s to be Ok. Unreal Launcher is ok, unreal editor is ok, visual studio is ok…

Is there’s a way to generate manually with and exe or bat file ?

Reading the forum, I find the name of a .bat file wich generate the vs file, but I dont find it in the unreal directory.


has already an answer for your question here

Many thank and

I’ve made a .bat with the command given in the link you gave me, it’s work fin.