Download

[Fetal Error] Error during map cook, FmemoryWriter, Archive.h. Can not update map.

I’m getting a error while cooking my map.
The Error pops up during cooking.
As soon as I dismiss the error, I get the cooker message that the map cooked successfully, however the “Upload” button is still grayed out.

Map was successfully cooked in prior dev kit versions, this is the first time I’ve tried cooking with the current version.

edit Solved partially. I found the problem. The cooker didn’t like the amount of extra landscapes I had in the map. (One along each edge of the main landscape and corners.)
Removing some of them fixed the problem.
The error reads:
**


Fatal error
[File:C\SVN_ark\Engine\Source\Runtime\Core\Public\Serialization\Archive.h]
[Line: 97]
FMemoryWriter does not support data larger then 2GB.  Archive name: 
D:/ArkDevKit/Projects/ShooterGame/Content/Mods/Roraima/maps/Roraima_main.umap.

**

Roraima_map.umap is the name of my main level for the map
The entire folder size for the whole Roraima folder is 1.23GB.

Changes I’ve made:
-on a few NPCZoneManager actors I changed “Min Desired Number of NPC” and “Max Desired Number of NPC.”
-imported a new texture into my maps main director
-used new texture as in game map
-under the World Settings I set “Override UIMapTexture Filled” and “Override Weapon Map Texture Filled” and “Override UIMap Texture Small” to the new texture
-under world Settings I set “Override Weapon Map Texture Filled” and “Override UIMap Texture Filled” to pages_topclean_map_bc (game/primalEarth/weaponGPS/textures)

I’ve tried cooking after these changes, as well as reverting back to before the changes were made except the changes done to the NPCZoneManager entities (I can’t go back further then that unless I just change them back to their original number pre-update.)