Feeling Silly, But: How to Import a Room?

Hey y’all, I’m calling again to look for advice.

I wouldn’t have thought this would be a problem, but I’m having difficulty importing a room (a static mesh) into UE4. Specifically, I don’t know what to do about the collision. I’ve imported dozens of static meshes but none of them needed to house the player inside of them. In this case I made a customized collision, but when I go to place the Player Start cylinder into the room, it flashes “BAD SIZE” at me and falls through the floor when I open the game.

So, I’m realizing I don’t actually know how to make and import a small, simple room. I can’t simply block out the boundaries with volumes – or I shouldn’t have to, anyway – and I’ve heard that cutting the model up into pieces or tiles is an unnecessary draw on performance.

I made the static mesh (and its collision) in Blender, if that matters.

Like I said, I’m feeling silly, like I missed something obvious, but I hope someone can help.

How to create a proper collision: For a building the 3rd way would be the easiest and best way. :slight_smile:
When you created a custom collision in blender, make sure that you disable “one convex per…” + “auto generate collision”

Bad Size -> the room has to be larger

Thanks, Fighter, you’re the greatest! I’ll check that out as soon as I can.

Okay, I’ve been through the video, but I’m still in trouble. I’ve disabled One Convex Hull Per UCX and Auto Collision and tried a few different versions of the UCX mesh, some higher poly than others, and I’ve tried scaling the room up to the size of a coliseum, but no matter what I still get the “Bad Size” warning. Also, if I uncheck One Convex Hull Per UCX the collision kind of loses its shape, stretching out at odd angles.

Could you post a picture of your collision? (in your 3d program + how it looks like in your building)
Also make sure to use the “complex as simple” way :slight_smile:

Sure thing. Here’s the model and its UCX counterpart in Blender:


I spread them apart for this screenshot. Except for the detail of the window and doorpost, they’re identical.

Here’s what they look like once imported into UE4:


As you can see, something weird happens to the UCX counterpart along the way. This is Auto Collision + Use Convex Hulls off.

But, I also took your advice and switched on “Use Complex as Simple,” and this helped things quite a bit: the UCX mesh is completely disregarded and instead it seems the collision is taken from the static mesh itself. This works pretty well, although the detailed pieces – the window and doorpost – have very sensitive collision. Small price to pay, though.

Why not try to separate the floor from walls?

Hi, I am new to UE4, but I know blender very well. The picture you have been posted suggested that the convex normals are in wrong order. If you don’t like to put thickness on walls, you may need to separate the walls from your floor. Otherwise, the “Auto Collision” would perform the object as an object with opposite normals.
There may have two things worth to try: 1、Let the walls and floor have its thickness; If you think that lead to too many useless vertex, then 2、separate the walls from walls.

Sometimes you get that error too, when you duplicate your object and rename it to UCX_whatever.
Your UCX_whatever can consist of many different basic objects.
Try to block it out with primitives (boxes for example), add them in edit mode, inside your UCX_whatever.
I like that more then autocollision, but convex shapes, like yours, or caves/tunnels are a bit tricky, to make it working well.
If you try to build convex shapes with primitives, you get quick dazillions of collisionboxes.
I can make a screenshot of my poor singlefaced convex dungeonparts.
If you need exact collision and whant no thickness, where the circle is, then you have to build many primitives.

Thank you so much, all of you. It turns out giving my colliders some depth and splitting them up into pieces really solved things. I’ll try to keep that in mind for future meshes.