Feedback on the new docs site

On the FPS tutorial page:

2 - Implementing your Character | Unreal Engine Documentation

…three is mention of an FPSCamera class, which doesn’t exist. My guess is that it used to exist but the tutorial was updated at some point and all references to it were not removed.

Secondly, the part where it asks you to move the default position of the camera so that it is near to the character’s eye level doesn’t work. It asks you to put the following code in the FPSCharacter constructor:

FPSCameraComponent->SetRelativeLocation(FVector(0.0f, 0.0f, 50.0f + BaseEyeHeight));

…this did not work for me. I moved it to the BeginPlay() function and it worked as it should, so it seems that the constructor was called too early before some other dependencies were initialised maybe.

FYI the reason SetRelativeLocation() was not working was because it just sets the default for that component. But the previous value will still be set in the Editor. So you have to go into the Blueprint Editor, click on the relevant component (in this case FPSCameraComponent) and in the Details section find the relevant value (in this case Transform->Location) and click the yellow reset-to-default icon next to the value. You’ll have to do this for some other stuff too.

  1. Pawn page: Pawn | Unreal Engine Documentation
    The last sentence of the first paragraph is cut off:
  1. Camera Components page: Camera Components | Unreal Engine Documentation
    Typo in the sentence (underlined):
  1. Transforming Actors page: Transforming Actors | Unreal Engine Documentation
    Potential missing embedded icon in the sentence (underlined):
  1. キャラクター設定の完了の2項目の日本語がおかしいです。
    「2.グラフ内で InputAxis MoveForward Event と InputAxis MoveRight Event を 右クリック して追加します。」

This page is outdated: Android on Linux Quick Start | Unreal Engine Documentation

It should be updated with the steps outlined here: Updates to required setup for Android NDK 21 in Unreal Engine 4.25 - Unreal Engine

Editing off:

The Aperturedefines how sharp or blurred the foreground and background are based on the diameter of the Diaphragmwhich is controlled in f-stop.

  1. Common Actors: Common Actor Types | Unreal Engine Documentation
    Under “Gameplay Actor Types” > "Triggers", the first sentence is incomplete:
  1. Trigger Actors: Trigger Actors | Unreal Engine Documentation
    The same as (1), replicated in the first sentence:
  1. Trigger Actors: Trigger Actors | Unreal Engine Documentation
    Grammatical error (underlined):
  1. Working with Level Assets: Work with Level Assets | Unreal Engine Documentation
    grammatical error (underlined):


  1. The DataSmith importer page: Unreal Datasmith | Unreal Engine Documentation
    This page, at the bottom, links to another page, which is also in the page hierarchy, that seems to not exist. It is labeled “Datasmith-Supported Platforms” and the link is Upon visiting, I am redirected to a default docs page (broken page?) with the link

The page titled Events, which describes events declared with DECLARE_EVENT, needs a deprecation notice. It describes features of events that are unenforced and they are considered deprecated according to a comment in DelegateCombinations.h:

* Declares a multicast delegate that is meant to only be activated from OwningType
* NOTE: This behavior is not enforced and this type should be considered deprecated for new delegates, use normal multicast instead
#define DECLARE_EVENT( OwningType, EventName ) FUNC_DECLARE_EVENT( OwningType, EventName, void )

For more detail, see this github demonstration project.


A Video can’t play In the middle of that page.
Error says No Source video was Found.


While I was going through the documentation page, under **The Default Interface **I see the reference Image is wrong, which shows the content browser as a viewports ad viewports as a content browser with wrong numbers on it.

Hope it will get fixed so that newcomers like me won’t be confused.


Control Rig Blueprint documentation is still hugely out of date. No mention of MetaHumans or definition for Import FBXTo Control Rig etc. So much missing as to be useless.

There should be a comment section at the bottom of the page.
For example:

I read it several times, watched 2 hours of videos and still didn’t understand how to configure Frustum Culling and I didn’t find any example of how to configure it. If there was a different type of comment or explanation in the footnote maybe it would be easier to understand.

Hello, im trying to follow the guide doc on vertex animation
Vertex Animation Tool - Timeline Meshes | Unreal Engine Documentation
and all the videos are missing. i get ‘ERROR no source found’ so just reporting that. cheers.

Hi, there are a couple of errors on Using Cluster Events | Unreal Engine Documentation

  • The first two bytes must give the total length of the rest of the message.

should be

  • The first **four **bytes must give the total length of the rest of the message.


By default, the primary node listens for Cluster Events on port 14003

should be

By default, the primary node listens for Cluster Events on port 41003

I wish Unreal Plugin Language | Unreal Engine Documentation had been updated to list all Android and iOS sections and provide more detailed explanation for each of them.

Hi, I’ve figured out a small mistake on this document: Add a Surface Type | Unreal Engine Documentation. The first picture should be highlighted at Project Setting, instead of Editor Reference.


Creating Custom Landscape Importers | Unreal Engine Documentation says

and then

I believe that last one should instead say ILandscapeWeightmapFileFormat instead of repeating ILandscapeHeightmapFileFormat.

Hi there!
How to load the datasmith file on runtime?
I’ve tried this two link, but still can’t figure out.
I can’t find the “Construct Datasmith Scene from File” node.

Use this node “Load Datasmith Scene from Explorer” but nothing happened!

Thanks in advance!

The course, ‘从另一个骨架网格体复制姿势’ (Copy Pose From Mesh), shall be useful but it is totally mass up and meaning less!
I have followed it step by step and finally got the set result, but, it mixed with ‘third person character’ and ‘third person character 1’, so that I don’t know how to apply this method to a real third party character such like ParagonYin, whose Blueprint folder and whose mesh folder should I look for?
Why don’t use a real third party character to explain this method clearly?

need off-line document
because china network slow