FBX Skeletal Mesh Import FAILS

Sorry for this post but i just cant find a post that states my exact issue

issue is as fallows when importing to UE4
Import defaults to Static Mesh
when Selecting Skeletal Mesh i get the fallowing notice in yellow text
Warning Asset does not appear to correspond to selected type and may not import correctly.

when i go to click import i get the fallowing error in the Message Log
Failed to find any bone hierarchy Try to import as Rigid Mesh option enabled.
import failed.

i created a skeleton using UE4 ART tool plugin for Maya

Maya 2014 with Service pack 4
FBX is currently set to Binary 2013 also tried ASCII 2013

note the steps i had taken to setup/export in fbx is the same in the video provided by UE4 Tutorials

just as a side note the fbx imports perfectly in Unity 4.5 and views correctly in the free FBX Review provided by Autodesk.

Bump information update.
my gun skeletal mesh imports just fine with the current fbx settings
yet the skeleton made with the UE4 ART Tools for Maya doesn’t register correctly. no matter how i attempt to change the fbx export.

anyone know of a special procedure that is required to export ART skeletal meshes?
as i am at a loss.

Okay all. i have found a issue with the Version of maya i am running. the Export selected doesnt work correctly or im just not doing it correctly. as when i do a export all then load that fbx into UE3 Editor it reads it fine. VARY VARY ODD!

Same here… In Maya 2014 (no service packs) Export selection → static mesh recognized. Export All->skeletal mesh recognized. Quick comparison of the two files reveals that Export Selection does NOT export Bind pose and Skin Deformer. No matter what I try. So, the only way is to Export All, but then the control rig gets exported, with a million things nobody needs in the engine.
But then I tried the same in Maya 2014sp3 and Maya 2015, and it worked in both. So the solution is to install newer Maya or Service Pack.

just to correct my previous post the version i use is Maya2014sp3 and i continue to have this issue. i just get around it by selecting everything i don’t want then, deleting everything except for what i want to export then do a export all then once exported i do a ctrl-Z to do a Undo bringing everything back. its a tedious task but at the moment i have no other way around it.

Hey OmeNu -

First just to check are you selecting your mesh and just your root bone when you export selection. Also try with the 2014 FBX which as long as you have 4.2.1 or later should import into the engine just fine.

Thank You

Eric Ketchum

tried both fbx 2013, 2014. i have also tried just selecting the root as well as the entire bone Hierarchy when doing a export selected. current version of unreal engine being used 4.3

Ok here’s what solved the problem for me:

  1. Delete non-Deformer History on the skin. Without cleaning it up, the skin deformer or the mesh will fail to export.
  2. For the animation export, in the FBX options, uncheck the “Constraints” checkbox. Otherwise, if you have a control rig controlling the skeleton, the animation curves won’t bake out propery.
  3. Select just the mesh and root of the skeleton to export; if the skeleton is parented to something, that something will be exported, too (does anyone know how to aviod that?). And all bones must have unique names.

After these fixes, I got my skin, skeleton and animation import correctly.

Okay All i know this is off subject and i do thank you all for posting suggestions in regards to my issue.
i decided to try the 2015 trial version of maya and know i have a issue with the ART tool as you can see in the picture the edit character selection window size is wrong and wont let me select my current project character. is there a fix or work around other then going to the directory and opening it directly?


Hey OmeNu -

Though you may have already found this answer on the forums, You can go into the *.py and edit the file to change the Windows the tool generates to be sizeable. By no means does this guarantee that there will not be other problems.

Here is a brief rundown on a way to fix this issue you are having. Before you begin make sure you have the latest version of the ART installed and my suggestion is make a back up of any file you alter. You can then open up the ART_skeletonBuilder_UI .py, which is in the General\Scripts\ folder in your original ART directory and run a word search for “sizeable = False” and change the False to True.

If you are really not comfortable missing or looking at coding, I would suggest you wait if possible; it is an issue we are aware of and are working on supporting 2015.

Thanks -

Eric Ketchum

yeah i found a couple of threads with i believe you responding about editing the python file and i attempted to do so using Notepad ++ i changed every line stating sizable = False to True and it still gives me the same effect. which is odd.

update: I have gotten the edit character window to resize. i had to change the fallowing

Python file “ART.Settings.py”
window code ref AnimationRiggingTool_SettingsUI sizable = True

Not the python file

Update had to Edit ART_skeletonBuilder_UI.py for other windows such as Publish character. you know which you have to set to True as the name of the window is located in the code area Title. so if there is anyone else attempting this its rather easy. anywhoo thanks for the info Eric Ketchum

Hey OmeNu -

Thank you for hunting that out. That original workaround version I generated to help Jeremy Ernst out because he is a busy, busy man. I never went back and checked the newest version of the tool when Mr. Ernst released it.

Again Thank You

Eric Ketchum