FBX Skeletal Mesh import crash

I’m trying to import a simple skeletal character mesh into 4.8.2 using the FBX pipeline, but when I hit import after selecting my settings it hangs at 75% before crashing the engine. It seems like the process is just constantly trying to allocate more and more RAM until it eventually just dies. I’m exporting from 3DS Max and using the CAT rig system, and I’ve checked the file for errors and problems by importing it into a blank scene and re-exporting it again, to no avail. It’s a simple mesh, no more than 10K tris, so I can’t think as to what should be causing this?

My crash report -

my import settings -

Hi brennt -

Thank you for your report. I have been attempting to reproduce the crash with a few Max CAT rigged models we have here and have not been successful as of yet. If possible, can you upload your FBX and MAX files here for us to test? If you would like to keep them private, feel free to send me a link to the files via the UE4 Engine Forums Private Message.

Eric Ketchum

Hi eric, thanks for the help. Here’s a link to FBX and MAX files -


Update: I’ve managed to get the mesh to import (finally) by removing the hands - seems like something in them is causing the crash, not sure what at the moment. But now the mesh is importing without it’s second UV channel -

Any ideas as to what might be causing the UV’s to not import correctly?

AH i fixed it, had to set the UV Coordinate index in the material. Still no idea what was wrong with the hands mesh…

Hey brennt,

I took a look at your Max file and ran some quick test to determine how or why you are getting this crash on import. So first I wanted to see if I could get the crash to repro, which was successful. Then I went through your Max file and began to delete/remove certain things. I eventually got all the way down to strictly the geometry for the character.

I was still getting a crash even with it completely stripped, but at a closer look I noticed you had not collapsed any of the modifiers on your character. You also had two character hair meshes resting within one another. After collapsing the modifiers on your meshes and deleting the extra hair mesh the model imported almost instantly.

Hopefully this gets you to a working point. I would suggest importing your character in iterations to make sure your character imports after making changes. That way, when it comes time to do the final import for your character, you do not come across any issues that could cause you to back track.


Thanks a lot Andrew! That’s a great help, finally works now!