FBX Scene Import as STATIC? (bug?)

I can’t tell if this is a bug of the new implementation of FBX Scene importing, or if I’m just misunderstanding the intended use of this feature.

This tooltip seems to suggest that toggling this checkbox will set the objects within the scene to static, or not. However, when I turn this off all my actors within the scene are set to MOVABLE.

Is this a bug?

Hi hypersapian,

This was a bug that was reported recently with UE-32354 and has already been fixed internally. Look for this to be fixed in the next major release.

Thank you!


Thanks for this. I’m also noticing I my objects lose their “overridden lightmap resolution” setting. Please let me know if you’d like me to start a separate report (not sure if it’s a bug). I’m basically trying to setup a workflow where I can knock out a scene in max and with a maxscript jump over to UE4 and hit update and rebake.

From what I see this isn’t a bug with the overridden lightmaps. When you go to File > Import into Level this will reimport and overwrite anything that was imported before. So this is expected behavior just like using the normal import method through the content browser.

The intended method to be sure that something isn’t overwritten is to use the right-click Reimport option. You can do this on the individual assets or the FBX Scene Import Data asset that is created in the Content Browser.

Hmm. So if I have a scene in max and move a table and export/reimport the fbx scene node in UE4 - the scene updates but but I have to redo all the UE4 related work - such as set everything to static and go through all the objects and reset up all the lighting overrides etc.
This would be OK for a one off but becomes a time sink with iterating back and forth between a DCC/UE4.

Is there a way to update the fbx data without losing the local changes in UE4? I get that the static override is a bug but it seems like I’m perhaps getting the workflow wrong. I’m also having to redrag the scene fbx in each time as the auto reimport was crashing (I manually trigger a re-import now).

Another issue with iterating is that when dragging objects into the viewport (such as the whole scene in this case) they don’t get dropped to world zero. In Unity I’d do this by dragging into the equivalent of the world outliner (but UE4 doesn’t seem to allow this). I’ve tried dragging in by holding ctrl / shift combos. I have to manually zero out all three fields of the transform each time. Again would be ok for a one off but if I’m building a scene in max and looking for a fast 1:1 iteration process then it’s a problem. I couldn’t really find any docs about the pipeline. I did notice some other options for scene fbx import that I haven’t tried yet (I’m currently importing using the default blueprint method).

My current tests involve:

  • make a change in 3dsmax
  • scene export via maxscript
  • delete current scene data
  • right click the scenefbx node & reimport
  • drag scene into viewport
  • zero out transform
  • select all subobjects in world outliner
  • set to static
  • override parts for lightmap

I entered another ticket for the overridden settings happening when reimporting into a BP. I noticed this only happened when doing it for a BP and not if you used the other two options for the scene.

For reference the ticket is UE-32807

Thanks Tim

Was this resolved? I’m having the same issue.


Both UE-32807 and UE-32354 were confirmed fixed in 4.13. If you suspect you have a similar issue it’s better to open a new ticket and post the steps to reproduce the issue. You can link to this post as a reference, but for clarity and less confusion please open a new ticket in Bug Reports and we can investigate from there.

Thank you!