FBX Re-import Not Overwriting UE4 4.19

Hello fellow Devs!

I am having an issue with not being able to re-import FBX files.

  1. Export model from 3D Software as FBX to project folder
  2. Import model into Level with File/Import Into Level (This preserves the model’s pivot point)
  3. Setup collision on model’s StaticMesh
  4. Make edits to model in 3D Software, export to same folder in project to overwrite initial file
  5. Select StaticMesh and select “Reimport”
  6. The model is not overwritten or actually updated

If anyone can please help with this issue I would sincerely appreciate it. This might be user error with my workflow or a bug or engine limitation.
If this issue has already been posted or solved, I apologize, I could not find anything

Thanks for your time!

I always import from a folder that is outside of the unreal project folder. Try exporting from your 3d program to a location outside of the project folder and then import it from there into your unreal project. Also are you importing into a folder within the content folder?

I have this problem too - in a project upgraded from 4.18 to 4.20. Everything worked fine in 4.18 but the FBX re-import in 4.20 just does not change anything. It’s a big, active program and we desperately need this to work!

Hello Danderson and Derek, thank you for the posts. I will try importing from outside of the project folder and see if that resolves the issue. Derek, good to know I am not the only one seeing this issue. If you find a workaround I would appreciate if you post back here, I will do the same. Thanks again!