Download

FBX Maya Export to Unreal Engine 4 Issue - Creating random invisible walls?

Hello everyone! I am a game developer (obviously), and for my game I am making a majority of my assets in Maya… HOWEVER there is an issue. In Maya, I do “export to unreal engine” and export what I want to the correct folder. Simple enough. BUT when I go to import the FBX file in to Unreal Engine, a couple things happen which I can’t comprehend. The mesh when put in to the engine is visible as to be expected, but has HUGE invisible walls surrounding it to the point that I can’t even access it. For example if I imported a structure, there are a bunch of invisible walls around it varying by the size of the imported asset which block and restrict player movement. Is this possibly caused if I export 2 objects that are separate from one another by a distance? Or would it be on Unreal’s side of things? I have tried editing the imported mesh itself in unreal engine, and it did allow me to enter where the mesh was placed but the mesh would become invisible and no collision with it either. The imported asset never appears as a landscape either, which is fine as long as it acts as one and has unit collision and everything.

I am also wondering if there is a way to edit imported meshes inside of Unreal Engine so that if I import an asset and find one side of it isn’t shaped properly I can use the built-in tools to edit this and “perfect” it. This would save me a great deal of time because for some reason, unreal engine also doesn’t let me use the weathering tools on this imported terrain.

The other thing is that I am working with a large game world, so although it might be unrelated to this thread, I am wondering if there is a simple keybinding or button that keeps me in perspective view and allows me to take a “birds eye view” from above, so I can use the “go here” command to navigate my way around easier?

Thanks in advance to everyone! Much appreciated

If the object you import is concave, then the “normal” unreal collision box will prevent you from entering.

Hey Shikarra,

Sounds to me like you should check your collision mesh. If there are open holes in the object used to simulate collision for your mesh, it could create the effect you’re describing where there are invisible barriers.

Alright, I’m going to play around a bunch with it tomorrow and try to see if it’s maybe the way I exported it from Maya, and if that doesn’t work then I will try with a couple other things that I think could’ve cause it. Worst comes to worst, I will upload the file or a screenshot or gif or something showing whats happening. Should hopefully be able to solve it. Thanks for the help! :smiley: Would it be preferred if there was a new thread created or a comment was posted on this thread to keep everyone updated?

You should probably follow up in this thread just to keep everything organized in one place, and so that those facing similar problems can be aware of the solution. =)

When you have the mesh open in unreal editor, at the top you can enable the collision, so you can see it. This way you can check if it’s the correct collision you have. I had the issue, where collision didn’t work at all, and when I viewed it in the editor, it turned out that it was offset far away from the parent model. In your case, you might have also ticked the box “Create collision” when you import it.

Good news everyone! I figured it out :smiley: All I had to do was, as McGreed said (great name by the way), turn off auto collision, and from there I learned how to create my own collision on objects from scratch and it did take quite a while to make it perfect and get the hang of, but it did work. Thanks for the help, it’s much appreciated! :smiley:

Im not sure, but I may have encountered this problem…I created a mesh, and its collision in maya. The mesh itself was created to be scaled up in the unreal engine (by 10%). I created a little space between the object and it’s collision. So, when I went to scale up the mesh in UDK, I also scaled up the space between my object and it’s collision, and couldn’t approach it with my player character as a result…make sense?