Download

FBX imports at 1:100 scale and is automatically scaled up again

I’ve noticed when importing FBX files into Level
File > Import Into Level

Any FBX files I import from Blender are imported as scaled down by 100 and then scaled up again in the scene by 100.

This means they display correctly so things work fine.

However, when importing objects that should be of a fair size ( 1m x1m cube) I get a warning

“Warning: The imported mesh is very small. This is most likely an issue with the units used when exporting to FBX.”

How can I get these files to not be imported at scale 1:100?

If I simply click in content browser and chose “Import Asset” they get imported at the correct scale, but I like the FBX scene file that gets created when I import them using the File > Import Into level method. This allows me to reimport the entire file (containing many FBX meshes) at once.

I’ve tried setting units differently in Blender, in the scene and in the fbx export dialog, but still get the same results in UE4

UE4 Version: 4.18.3-3832480+++UE4+Release-4.18

2 Likes