Fbx importing/shading/lightmaps

Hey, I looked at the screenshot, and before I go digging around in the model, my concern is that you don’t have a fully UV mapped model. Shading errors like this are usually caused by overlapping UVs.

Hmm, I just imported the FBX you linked with no issues. Still digging around.
Also, Kudos on the nice model, I wouldn’t openly share something like that. Someone will steal it. =P

Hey! I’m really struggling to get my model from blender to UE4. I’ve been trying for the past 5 days and i cant get it to work. Everytime i bake a lightmap i looks completely wrong and i believe it’s due to the importing of the shading.
I put the whole blender project on my dropbox and also the fbx file. I know, most of the model isnt uv unwrapped but lets just focus on the wooden planks at the bottom. I appreciate any kind of help. Kind regards, Philipp

i included a screenshot in the download link

Kind regards, Phil

Yes, the model isnt fully uv unwrapped. but I’m just talking about the wooden planks at the bottom. They have a UV set for the textures and a set for the Lightmaps. I tryed it with overlapping uvs and non-overlapping UVs (for the texture). The lightmap uvs arent overlapping of course.

i also tried this method: [Blender] Same model but different shading quality? - Asset Creation - Unreal Engine Forums

Figured it out. I was having SOME issues with it. The problem that you have is the geometry holes. When you model the paneling, close any open boxes.

Thanks. Honestly, i dont care if someone uses it. You can generate correct lightmaps? what are your export settings?

Ok, thanks!! I’ll try it out!

honestly, i still have the same problem! i put the screenshot in my dropbox, because im having problems with posting a picture.
Am I an idiot? I set the quality to production quality and the resolution to 512. did you use my fbx or did you import it from the blend file. if so, what export settings did u use?

I just used your FBX. With a default import. Can you give me the FBX with the closed geometry holes?

Try discarding all normals and have the editor generate new ones?

I uploaded it into the same folder.
OK, I’ll look up how to do that an respond then!

ok, I just took the new closed FBX and had absolutely no problems. Even the default texture looks good.

I tried importing into Blender and Cinema 4D. No issues whatsoever. The geometry is good. One issue might be the two sets of UV maps applied, just delete one. Maybe you are using the geometry at too small scale in the project? I seriously am running out of ideas here.

Here are the import settings I used.

Small scaling can lead to errors in the lightmap!

I can believe it! It was the scaling! Thanks for your help! you were very comitted!
I scaled it up (10x) an it worked flawless! Thanks again! You seem like a great guy!
Kind regards, Phil