Download

FBX importer is a massive memory hog :O

Do not try this at home kids — I created a test landscape mesh in blender which was 2000x2000 vertices and exported it to a FBX static mesh file. I then attempted to import the FBX file into UE4. It seemed to take a really long time… an extremely long time… a “go to lunch and come back in an hour” long time. The reason is the importer is hogging system memory like there’s no tomorrow. The importer grabbed all 16GB of system ram plus another 3+GB of swap space to import this one file. This brought the system to a glacial crawl. I got to ask: Yes, a 4 million vertex mesh is unusually large, but is it really necessary to grab 20GB of ram to load it?

Turn off automatic collision generation and turn off automatic lightmap generation, that’s probably why it’s having an issue. Maybe for the collision it’s treating the geometry scale accurately.

I don’t use either of those. They were already off. The issue seems to be with the FBX library itself. I’m assuming Adobe supplied those. For grins, I tried importing the mesh back into Blender 3d as an FBX. It did the same thing.