FBX imported Blender NLA stripes are wrong in UE4 when connected in serial

I’m not sure if it’s a bug or it’s caused by my settings but I’m reporting it. Also, working on 4.19 right now, could somebody check that on 4.20?

I will describe a bug by two different cases:

Screenshot is from Blender’s NLA editor. Situation 1 and 2 differ only with that small GAP in between the animations. One animation is pressing the button, the second one is releasing, as the names suggests.

Now let’s import FBX file to UE4. The import settings in UE4 are left default. Here are two cases described above:

  1. The animation playing is release, but the animation contains frames which first pushes button down (from starting position of K.Dot_Pressed) and then pop the button up (as it should do in K.Dot_Release). So the animation’s first frame is wrong, and only the first frame. At frame 1, the animation “K.Dot_Released” is playing correctly from the position it should. Maybe it is somehow related to blending between the strips as the added movement to the bottom at fram 0 is finely interpolated (it plays smoothly, not jumping).

  1. The animation playing is release and it plays correctly, when there is a gap in between strips. At frame 0 it is at position it should be.

In Blender, in both cases, the animations behave correctly. Blender version: 2.79b. Here are my blender export settings:

It’s not really a blocking bug or important, but I hope it might be improved in the future so I report.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Thank you Jeff, sir, for information! Didn’t know that. I’ll do it in a spare time. I just thought of, maybe the link and short explanation appearing in red when clicking “bug” in category would be handful.

Have a nice day!