Download

FBX Import with hierarchy

Hi folks,

I’m completely new to UE4, so maybe this is a quite stupid question. But I’ll ask anyhow.

I have a model in 3DSMax which consists of a hierarchy of objects. In fact, it’s a conveyor composed of a frame and rolls which will transport whatever is lying on top of them.

Now what I want to do is: Import this model to UE4 while still being able to select and transform (in this case: rotate) it’t child objects.

Is there any way to do so?

Thanks in advance and best regards,

Sven

You can import it as a static mesh and uncheck Combine Meshes in advanced, then you will get every object as a seperate static mesh and can re-assemble the hierarchy in the editor.

You can also import it as a skeletal mesh and check Import Rigid Mesh, then you will get a skeletal mesh that uses your object hierarchy as skeleton. You’d have to use blueprint (or code) or animations to rotate the specific parts though.

Thanks for your reply,

the import as a rigid mesh seems to be the way to go, even if I have to find out how to do some rotation from code.
But there’s one thing: When I import the mesh this way, all the pivot points of my child elements are wrong (even if they are set correctly within 3DSMax), so there’s no way to make an object rotate around it’s own center. Is this an user error or do I have to fix this somewhere on the way from Max to UE4?

Make sure the conveyor’s frame is set to 0,0,0, then make sure all the rolls have their pivot points set to their center and then link them all to the frame. Finally select all and export.

Did that. I made the frame, adjusted it’s pivot to where I want it to be, then added the rolls, placed their pivots in their centers and then used the “select and link” to link them to my frame. Result in UE4: Pivot of conveyor is correct, the rolls’ pivots are way off (translated many meters in x direction)…

Hmm, they may be requiring an Xform modifier. Select the rolls, Reset Xform for all of them then convert to Editable Poly and try again.

I added an XForm modifier to the rolls, then reset the XForm via the tools menu and converted all the rolls to an editable poly again. Then I linked them to the frame and did a fbx export.

But: still no success. The pivot points are still away from their intended location. There is also no “logic” behind this offset, as far as I see.
I tried importing the conveyor as a static mesh without combining the components. I was able to reassemble the model by placing all parts at the origin but I also found out that - when I do it this way - the pivot Points are also offset. BUT: they are all in the same place which is the frame’s pivot location.

Very strange. To me this seems like a bug either in 3DSMax or the FBX importer. I’ll try to assemble a simple model with blender and then import that, maybe this will work.

Does anyone, however, have an idea what the solution to my problem could be?

If you import it without combining, the origin of every object will be at what’s 0 0 0 in your modeling program. To do it that way, you need to move every object so it’s origin is at 0 0 0, then export, then move them back.

I modeled some very basic example (a box and a cylinder) in blender (****, have to learn that tool…) and imported it. The same applied here: When I edit the imported object in persona, the automatically created bones are there but they are also offset. But not that much as in the 3DSMax-Export.

But: This still isn’t of any use for me. I get quite frustrated. I’ve done some stuff in Unity (yah, i know…) and when I import some FBX in there (no matter if modelled in Max or coming from Inventor or NX and converted to FBX) I have absolutely no problems with rotating or moving anything about it’s given pivot point.

Is there some tutorial available on how to build up a model in a way that makes UE4 accept those stupid pivot points and allows me to simply move parts of my objects around? I really don’t get whats happening there but none of the tips above could get me one step further.

Importing objects without combining really isn’t an answer to me because most objects I deal with have a rather complex hierarchy and I can’t spend my time putting them together in UE4 again…

Here’s an image of how it looks after importing…btw: why is scaling that wrong? Would expect that 1 unit in Blender is also 1 unit in UE4?

Bone.PNG

Before exporting something from blender, go to object mode, select everything (A), then press ctrl+A and apply Rotation & Scale. Make sure you export it with scale 1 in the FBX exporter. One blender unit is one Unreal unit if you do it right, but an Unreal unit is only 1 cm… that’s very tiny.

Ah, thats good to know, thought it was meters :slight_smile: I will try that…

Wohoo! It works!

SThis - however - doesn’t tell me why the Max-Export gets messed up, but it’s at least a solution. Thanks to all of you for supporting me, especially Zeblote :slight_smile: