Fbx import with animation is quitting UE4 due to shader compiler error message

Hi all,
it seems that UE4 [4.9.1 ]

crashes when a FBX file is loaded with animations in it.
with the error message that an assertion of the file “shaderCompiler.cpp” failed [Line 147]
sadly thou I don´t know how to fix this.

UE4 [4.8.3] loaded the FBX file(s) without closing itself.


Hi mrclay -

Can you reference the following wiki and upload a copy of your Windows Event Viewer log for the time around when this crash occurred?

Also please attach your DXDIAGs and if you are willing, a copy of the offending FBX would be helpful as well.

Thank You

Eric Ketchum

Hello Eric,

here are hopefully the right files, additionally the fbx file which is causing the trouble.
fbx file- in zip due to big size

Hi myclay -

The FBX you sent me imported fine into the editor with three animations (included a screenshot below). Can you perhaps post what Import settings you are using with the FBX and let me know if you are using a Launcher or GitHub version of the engine.

Thank You

Eric Ketchum

Hi Eric -

the error happens on my pc when during Import the Animation length setting is changed from Exported time to Animation Length
After that change whenever UE4 is opened and the file is being tried to be imported, UE4 puts out the error message even when you use the setting Exported Time instead of animated time.
Worst thing is, even closing the Epic Games Launcher and reopening everything still causes the shader compiler error like it remembers that there was an error.

Hi -

Can you take a look for the following directory on your PC and upload all the files found in it here?


Thank You

Eric Ketchum

Hi -

sadly I haven´t found the particular filename but I recreated the error again and have packed the newest crash report and attached it.
link text

Hi myclay,

Apologies for the delay. Using your asset and import settings I’ve not been able to get the same error.

In the logs provided above it seems like something in the shader compile is causing the issue though.

If you try importing the FBX without materials or textures checked does this cause the same error?

Also, have you tried verifying or reinstalling the engine for 4.9?

Hi myclay,

I’ve not heard back from your in the last few days. I’m going to mark this as resolved for tracking purposes, but if you’re still experiencing the issue you can simply reply here to re-open the issue.

Thank you!


Hi Tim and Eric, sorry for the delay, (the Game Launcher was unresponsive.)

disabling import of Materials and Textures does the Trick of avoiding this sporadic issue.
thank you very much. :slight_smile:

I encountered this same error too when converting 4.7.6 to 4.10.4. How do you know which asset is causing the crash? Error log doesn’t mention any filename or anything. Otherwise we will have to the ‘elimination technique’ which is cumbersome for large levels…


Make sure to check your logs in your project folder > Saved > Logs. Open the log and scroll down to the very bottom where the crash details are located.

You can find the asset name here that caused the error.

Did you try not importing the asset with the materials and textures? If so, did you still get the crash?

If you have a test asset you can post here and I can see if I can reproduce. Also include your epic/machine id’s and logs for reference. If I can reproduce it’s much easier to get a bug in and see if we can prevent this type of thing from happening.

Thank you!