Download

FBX import settings, sharing my troubleshoot results for wobbles and jitters.

For those having issues with importing animation that wobbles or jitters, before you go back touching your rigs try these settings in FBX import:

It took us one whole day to troubleshoot our issues with horrible animation wobbles we were getting on import. The FBX file itself was working fine tested in Unity, Maya and Max. We tested it in all frames settings and milliseconds as well as understanding delta time issues and interpolation errors that may come up, it was clean and working outside UE.

We went back and tested a million things on our rig, re-imported and re-exported countless times and it still never solved our issues. we altered import settings except the last two combinations, it was pure chance we unchecked and checked these two settings in that order specifically.

We are frustrated that we wasted a whole day when by default yet again Unity was importing FBX animations fine and yet again UE was giving us trouble (another issue related to morphs in my other thread that preceded this). We still don’t know what exactly changed with these settings and why these two setting are causing the wobbles on animated rigs and characters, The doc mentions something about removing zero value keys/curves but that could mean a dozen things.

If anyone can explain why this is so and why they aren’t set like this by default at least we can understand the cause better.

We are also always checking “use default sample rate” just to be on the safe side. in some cases it has produced more predictable results. So we just keep it on now.

can you cut the mesh to a basic (cull triangles or quads, remove an arm or something ) and share an unusable FBX so that it can be tested?

I am not getting the time to put a basic scene together because it would require 2 examples to demonstrate the problem after what we found out further, but I will try to do so, I have also yet to look into the engine code for the morphs that you suggested.

For the issue of this post, I spoke too soon, while the above method worked to visually get rid of the wobble, we found out there are rotation jitters on the numbers when we applied a print to check out how clean the rotation values are, because functions applied to the values where jittering.

We pin pointed the culprit to bone rotations on our rig that are being driven by Biped. For some reason UE did not like the way the bones were oriented even though they are moving correctly and has been a standard workflow for us that always worked, and what does bone orientation have to do with jittery values during rotations inside unreal remains a mystery. Sicne even if you have incorrect rotation angles the bones should not jitter like that.

We scrapped the bones rotations and aligned them all to the world axis in pivot mode inside max and re-rigged them, this time it worked, but if you look at the bone orientations themselves they are unusable outside the rig. It is the first time we run into such an issue since we have been exporting countless rigs for years now. And only Unreal gave us these jitter values in all versions of the engine we tested them in, Once again we tested in unity to make sure the fbx was “clean” and no such issues came up there.

At least we solved our issue for now but without really understanding the reason of the problem. I will try to post something when i get the time.

not so much, I wager this is a result of gimbal locking.
sounds like lit anyway.
If it jumps between 180 and -180, or 0 and 360 that’s what it is.
never had it happen on animations thoguh. Its normal to see it happen when using blendspace for movement driven by a rotation angle, its not normal at all in animations, especially not within Persona where the world location is 0,0,0, and the accuracy of the animation is maxed out.

If you could put the test thing together I’d be curious to dig in.

no blendspaces or 180/360 movements a simple dragged in animation as is, head turns 30 degees left and then chest 30 degrees. Will try to keep you posted. Thanks.

Thank you for sharing. I have solved my annoying problem. When I use the Biped system to output FBX and import into UE, do not imoprt curves will be checked by default, so I can’t find the problem.

Thank you for sharing and wish you good health