Fbx import problem - no smoothing groups

Hello

I have a very strange problem with my fbx files in the new beta version. I tried to import fbx files, that I have create some weeks ago, but somehow I can’t import smoothing groups anymore. The exactly same files worked perfectly with the older version of UE4.

  • blender → fbx files import correctly
  • 3d max → no smoothing groups

Any suggestions what could be wrong or where there any changes in the new beta?

Greetings

Philipp

After the import open your static mesh and enable Recompute Normals and Recompute Tangents Under LOD0 and save it. That should fix it.

You are a genius ;D Thank you for your answer, it works now. Have they changed that in the latest build of UE4?

Glad that it works. :slight_smile:
There was an answer to this same thing a couple of days ago from Epic, but I don’t remember if it is an intentional change or not.

Hi Philipp,

I am glad that you were able to resolve this, but we have not been able to reproduce any issue. An FBX exported from 3DS Max with Smoothing Groups enabled in the Export Options does not experience any issues for us when being imported into Rocket.

If you are able to give repro steps or provide any more information regarding this issue, please let us know.

Thanks

Hi

Here are my steps:

(As the 3d modelere from my team just has experience with blender, I always have to import the model into 3d max to create the collisions and LODs → it sounds a little bit inconvenient, but it saves us a lot of time ^^ )

  1. the 3d artist creates the model in blender
  2. he exports it as a fbx file
  3. I import it into 3d max
  4. I add the collision, LODs,… and then I have to click onto the smooth button, because 3d max disables the smoothing groups from blender
  5. I export it → you can see my export settings on the picture
  6. I import it into the UE4
  7. Now I get this weird looking mesh (picture)
  8. After I have enabled the “recompute normals” everything is like it should be

Export settings:

Strange Mesh:

After the recompute normals:

You can also find a 3d max file in the “Philipp” folder on the FTP Dropbox

I hope those informations are useful for you :smiley:

Note:
I used the same steps with the older versions of the UE4 → it worked well, that’s why I was a little bit confused

Hi Philipp,

Thank you for this information. I was able to successfully reproduce the issue by using an asset created in Blender, but given smoothing groups in 3DSMax. A report has now been entered into our bug database.

Thank you,

Alexander

Hi

I also encountered this problem and found that enabling recompute normals fixed it.

I also found that by having the FBX exporter in 3DS Max set to 2013 eliminated the need to have recompute normals turned on in UE4.

Thanks
Dan

Hey angelofdeath,

Thanks for your response, but this is an old archived answer from our beta users, put here for reference.