Download

fbx import normals broken

Hi
a fbx i used in unity and import in unreal i cannot get normals right!
Could I be doing something wrong or is this s* broken? I’ve wasted all day with normals…
Thanks

Hi Mike4,

Have you taken the model back to your modeling program to ensure that none of the normals are flipped? Try re-exporting it from your modeling software before importing it to the engine. If this does not help, please post this to the answerhub at http://answers.unrealengine.com in the bug reports section (link in signature) so we can assist you more in depth.

Please post pictures here so we can help you better.

If you have comparison images of what you expect it to look like from your modeling application vs what is imported into UE4, this can be helpful in diagnosing any issues.

More than likely it’s just a setup issue or something that can be adjusted in UE4 to see what’s going on.

When you post comparison shots please post a screen shot of the mesh in UE4’s Static Mesh Editor with the Normals toolbar button enabled as well clearly showing the troublesome areas.

Thank you!

Tim

Is that helpful? It’s a morph anim that works in Unity but in Unreal it seem normals are flipped and am unable to change that. A wave animation. Thanks for help, else I’ll submit
a bug report:

http://i62.tinypic.com/qzmaad.png
http://i59.tinypic.com/30ijlex.png

I have an answer hub post which illustrates the problem: Imported Normals are Inverted - UE4 AnswerHub

Can you upload those pics to the forums directly rather than something like tinypic. When I first clicked on the images they loaded fine, albeit a lot of ads on that site, but subsequent clicks to load the image only showed the ads. :frowning:

Also, can you include all your steps that cause this to happen and answer the additional information below. I’ve used Morph Targets from 3Ds Max with no issues with normals being flipped so repro steps here would be extremely helpful in trying to figure out what may be going on.

  • In as much detail as possible, list your steps to accurately recreate the issue from creating the asset to bringing into UE4. This is extremely helpful for us to do exactly what you do to recreate the issue and narrow down from there. Otherwise it’s a lot of guess work on our end that can lead to needless back and forth, especially if we don’t use the program you do, and we may not do a step that you do.
  • What modeling program are you using?
  • Is this happening only with Skeletal Meshes vs Static Meshes?
  • Are you using Morph Targets, if so, does it only happen on a skeletal mesh that uses morph targets?
  • Can you provide a simple test asset that recreates the issue that we can use as a test. If so, can you include the modeling program file and the FBX that recreates the issue?

I’m happy to look into this further and work with our guy on the Support Team that uses Blender to see where the hiccup is. I’ve assigned myself to the AnswerHub post for the moment while looking into this. You can feel free to carry the conversation over there (Imported Normals are Inverted - UE4 AnswerHub) as this would be easier to track, and there is more than one person experiencing this issue.

Thank you!

Tim

If there are no size restrictions I’ll attach the images here from now on.
I only import the complete fbx with textures etc… Changing normal settings has no effect at all
I did export from Blender but am happy that I got it working once for Unity. I’ve tried another export
today but can’t remember which settings I’ve used…maybe it’s the wrong blend file.
Can I give you the fbx? How, if I would prefer to keep it private and not for everybody to download?
Looking forward to get this working, thanks.

You can send a private message to me with the link here on the forums.

Got it working yeahh. Needed something like “save material for morph support”.
Great.