FBX Import: Mesh Naming

Ok, I know that the following is not an actual issue, but it hit my nerves every-time.

I work on 3D Studio Max 2015 and export to FBX 2014 version all the meshes.
I have separated my scene into different layers in max, and then exported each layer as a different fbx, each one containing multiple of meshes inside.

When I import the files into unreal, all the meshes take as a name prefix, the name of the fbx. This is getting very annoying, since I already have everything named correctly in Max, and in unreal the names get the unnecessary prefix.

Is there anyway to change that?
I want meshes in Unreal to have the exact same name as they do in Max.

Thanks in advance for any help!

Hey ,

When importing a mesh and viewing the import settings, there is an option within the ‘Miscellaneous’ section at the bottom labeled, ‘Override Full Name’. If enabled and the FBX file only contains one mesh, the name specified in the import path field will be used as the full name for the imported.

Uncheck this option as it is on by default. This should allow you to keep the original names that you set within 3ds Max for the meshes you are importing.

Thank you,

Unchecking or checking ‘Override Full Name’ does not let me keep the mesh names inside the FBX.
Doing it both ways adds the file’s name as prefix. is there really any way to get rid of the prefix name when importing multiple mesh inside a single FBX file?!

This is expected as that option does not handle the import of multiple meshes. This is stated in the explanation of the option within our documentation on FBX Import Options.

Take a read through the Naming Rules within the documentation to get a better understanding of how UE4 handles naming single and multiple meshes when the ‘Override Full Name’ option is enabled/disabled.

Let me know if you have further questions.

Thank you,

Ok so there is no way to get Unreal 4 to remove the file name as a prefix for the way I am importing?
I wish it handled that aspect the way UDK did which would allow for what I’m trying to do.

Was a solution ever found for this? For example if I export a modular tile set of 100 meshes as one FBX is there way to avoid the filename being prefixed to each module?

Hi, is very old question, but i have easy solution for this. Save fbx file without name, like that “.fbx”.

This issue is still present, was a solution ever found for this?

1 Like