Download

FBX Import Loses Detail

Hello

I’m using Revit 2021. The Datasmith and Twinmotion plugins aren’t currently compatible. When I import an FBX made in Revit into Unreal it loses a lot of detail. When I import this FBX into Blender it looks fine (see screenshots below). When I import into Unreal the FBX from Blender it also looks bad. Are there some import FBX settings in Unreal that can fix this file?

Link to FBX (One from Revit, one from Blender):

https://drive.google.com/file/d/1wUUI9nzTlHGqROkd_nv1S5VQsTXp4a11/view?usp=sharing, https://drive.google.com/file/d/1xmGRFkLbtTuK26DIeiA2J7cCeZz2e7Bl/view?usp=sharing

I have moved the FBX files closer to the origin but they still don’t work:
https://drive.google.com/file/d/1v5ir-yA9ODfqHGbUpOn8hOXw_HysHfZX/view?usp=sharing, https://drive.google.com/file/d/1x-llCPWFNmP1k8tJMQ1bqkQKsxjTEEKX/view?usp=sharing

The FBX imports correctly into both Quixel Mixer and Blender.

Try to triangulate the faces before importing the FBX into UE.

Try this, after importing open that static mesh and head to Details->LOD->Reduction Settings and make sure percent triangles is 100. If it is less than 100 it means triangle reduction happened and quality is reduced.

It might be using Nurbs geometry which needs to be converted to triangles to be usable in UE4 and most meshing tools that do that don’t do a good job, try converting it to a mesh in Blender and then export that to UE4.

post picture where we can see edges in blender (in 3ds max standard view with edges or wireframe) , this is obviously problem with wrong geometry in blender, UE4 is more with triangles, and you have polygons with multiple vertex, this is problem pipeline two programs, datasmith do good job but I prefer clean geometry.

Thank you everyone for your guidance.

The image at the bottom shows the LOD options - this doesn’t include any ‘Reduction Settings’.

The other image shows the Blender Wireframe View. It is a horrible conversion from Revit.

I tried both the Triangulation Modifier and ‘Triangulate Faces’ in Edit mode in Blender but neither produced a good looking FBX when imported into Unreal.

This is a little perplexing when the FBX imports fine into Blender and Quixel Mixer.

It does seem like CAD programs don’t play well with ‘Mesh based’ programs. I am hoping that BlenderBIM will manage to make a way of producing drawings in Blender. Of course when Blender is imported into Revit it also ‘looks dirty’…which will make it awkward for others to work with my files in CAD…

Would it be the reference coordinates are not set correctly during export?

Y in Blender is positive vertical, which is Z in Unreal. The forward facing horizontal axis is different between the two as well.

I tried ‘tinkering’ with these settings but without much luck: FBX Export Options.jpg

I would consider using 3ds max as a bridge from revit to unreal, it works better that way. Then you use the datasmith tool but in 3dsmax

Ah, yes! The 3DS Max route works well. Since I am using Revit 2021 I could only use 3DS Max 2021 - which doesn’t have a Datasmith plugin yet. I was able to ‘link’ in the Revit file (and using ‘reload’ I was also able to up to curves making the model much better). Then I exported the Mesh as FBX and it now imports correctly into Unreal. The UV’s look good too…

still you have too much polygons in simple object (around + on circle you see jittering and on top right around you see triangles bad geometry, you could make this with material normal map and opacity map it would probably look better and use less resources