Download

fbx import is ignoring the import settings? UE 4.13

This is confusing me big time.

I’ve already got a bunch of textured meshes into the engine and they appear exactly the way I want them. These were imported as 2014 fbx at an import scale of 0.5. No rotation was needed. They’re used in the game as is and are great.

I’ve just edited one of the original meshes so reimported and for some reason the mesh is now rotated 90degrees on X and is at full scale. I’ve tried changing the import scale and rotation a few times but they’re completely ignored.

So in order to check if my export was broken I tried a basic reimport of a mesh I’d not changed. Ordinarily it should import without any changes, it should be identical … but no … its scaled up and rotated 90degrees on X.

Hopefully I’ve attached an image that shows it. Non of those meshes have been edited outside of Unreal. I simply right clicked on WE_Town_Child_01 and selected Reimport and boom … that happens. It should look nearly identical to the others but is rotated and scaled… or rather rotated and NOT scaled … since it now appears at its original scale and not 0.5 as requested…

So the questions are

  1. Is there a switch somewhere that tells Unreal to ignore all import settings?
  2. Has Unreals fbx import suddenly changed? Is it reading or ignoring some fbx values that it wasn’t before?
  3. Am I clinically insane because this seems to of happened overnight without my knowingly doing anything at all.

Thanks.

‘Transform Vertex to Absolute’ … look like it had been turned off in the Import settings. While this had little to no effect on .fbx imported from Max, those from other software were a different story and required this turned on.