FBX Import into Level and standard Import scale difference (Blender)

I am having trouble getting a fbx scene from Blender to import correctly:
I saved out the default Box from Blender as fbx, changing nothing in the world or export settings.
Importing the fbx with UE4 standard Import in the Content Browser, not changing anything in the settings, everything is fine. Scale of the Box is 1,1,1 (see first image)

Importing the very same fbx with File -> Import into Level, not changing anything in the settings, a message saying “The imported mesh is very small” comes up, and the Box scale is 100,100,100 (see second image)

I tried dozens of export and unit setting combinations in Blender and can not figure out the solution.
Maybe somebody came across this already?
Thanks!

1 Like

Hi there! It’s FBX export settings, try to apply units scale and scale options NONE

2021 and still an issue. The standard fbx importer direct to unreal file system works great but importing an fbx scene from blender (2.93 at time of writing) using unreal Import Into Level gives same issue as reported here 3 years ago.

You can go through all the pain of scaling it up by 100% in blender etc. but you have to apply scale and it’s a pain with instanced meshes etc. This is a better workaround.

  1. Set units to Metric and unit Scale to 1
    image

2)Make sure everything has applied scale in your scene so it’s all at 1 [edit] actually you don’t need to do this works great so if you have instances mirrored and other scaling it comes across ok]

  1. Create an empty and parent everything you want to export to it [edit do not nest empties for some reason doing that makes the scale on the meshes go to 0.001 in the level even tho the mesh asset comes in at correct size so just have one parent empty per set of meshes and do multiple exports each with their own parent empty if you have large chunks of scene you want to group] Make sure main parent empty is at world origin and not scaled or rotated

Select everything you want to export to fbx including the empty

If you want to export instances do not apply modifiers or you will get a unique mesh created for each object instance so you instances need to be in a state that you want for export (i.e. triangulated with correct normals etc) and all linked with same mesh name.

Export as fbx and set it up like this, the important items are not to use space transform and select apply transform (just do it exactly how I have it in screen shot to start with)

In unreal open the level you click on import into level
image

select the file and select the folder you want to import into

In scene you should see all the individual objects that will get imported along with the empty as a parent

Select create content hierarchy if you want to recreate the parenting in the folder structure and Create Level Actors

In static meshes you should just see the unique instances

Hit import the scene will come in at 90 deg however all the meshes are the correct orientation in the folder structure and scale

Just select the Parent in the world outliner and set the rotation to 0

Now everything is the correct rotation all the individual assets have the correct rotation and scale and everything has the pivot point that you set in blender not defaulting to world 0, happy days.

At this point you can delete the parent in the world outliner if you want.

hopefully this helps someone so they can avoid the pain I went through figuring it out.

1 Like

One other trick as well, if you want to quickly set x forward before exporting the scene using this method if you select all the meshes you want to affect and then enable transform only origins in local space you can just do r z -90 and have x forward.

If you have instanced meshes then make sure you select all of them when you do it and blender will lock them in place adjusting the rotation to compensate which is a neat trick. you can test it out if you leave one out of the selection it will spin like they would if you just went into edit mode and moved the mesh but with affect only origins selected and doing it like that all the ones you have selected stay stationary as the pivot moves.

image

then in unreal you now have x forward as well if you want that for consistency.

1 Like

This doesn’t work for me at all. Made a Suzanne and an empty. Made the Suzanne a child of the empty. Exported the FBX with your settings exactly. Imported FBX into level. The Empty gets a scale of 100, the Suzanne gets a scale of 1, and the Suzanne mesh has 2x1x1 dimensions in the Static Mesh editor.

that’s weird, I used it loads after posting this to set up some complex scenes with 2.9 and 4.27. I’ve only seen it do that when I’ve say been working in mm with the scene set at 0.01 and forgot to set it back to 1 before I exported.

Don’t mind having a look at your test blend file at some point so see if I can reproduce if you like.

Mark

On export, make sure apply all experimental is checked.

And if you are doing new work, just set your scale properly in your start file so that you never have to worry about scaling issues again …