Fbx import ignoring axis?

Who ever goes around changing axis on an export anyway right? Right.
Well, I did it because I needed to flip an object to test, and apparently unreal is ignoring the axis upon import.

Can anyone confirm this?

The fbx is coming in from blender, but the dcc shouldn’t matter.

Mixer most definitely imports the mesh with whatever axis I export. The produced FBX can’t therefore be the problem.

The import settings aren’t rotated or altered as far as I can tell. It’s like unreal is literally just ignoring the axis. Not even sure how this is possible.