Download

Fbx import has less polygons?

I am currently trying to import a mesh into UE5 and am noticing that the imported geometry has less polygons than is actually in the fbx file and is causing some small visual issues. I have tried quite a few things, increasing the tessellation on my mesh, going back and forth from quads and tris, and every time it imports with exactly 2000 triangles. When I open the same fbx file in 3d viewer it reports the same amount of polygons as 3DS max (~6500) and looks fine. Any ideas whats going on?

EDIT: I should also note that I dont get any errors when importing!

Thanks!

Try untilcking “remove degenerate triangle” in the import options. UE looks at the mesh and removes triangles that have sides that are too small where 2 verts are on top of eachother, sometimes this setting sees a small gap but interprets it as degenerate.

are you using turbosmooth or any sub-d modifiers on your mesh?
when exporting untick turbosmooth in the fbx export options

are you enabling nanite at import?
nanite enabled meshes do not show the correct poly and vert count

Is this with your “Square Pit” model? It imports with 6482 tris for me, exactly the same as in the max and fbx files. This in both 4.26.2 and 5EA.

Edit : I think didel23 is correct. The same mesh reports 2000 tris with Nanite enabled on import

Turning off nanite did fix the issue, I wonder why this occurs… Thank you for your help!!

From the docs:

N O T E
In Early Access, the the Triangles and Vertex statistics displayed in the Static Mesh Editor refer only to the proxy mesh, whether or not Nanite is enabled. To see the original triangle count, Nanite must be temporarily disabled on the mesh.

1 Like