FBX import has flipped normals, how can I fix it?


If your object turns completely black after lightbuild it has problems with its lightmap (usually not existing/wrong uv channel!!) and not normals… usually when you have flipped normals your mesh/faces starts to glow/emit light!!
…anyway you should be able to fix it in your 3d app!!

In Unreal usually what can help is to uncheck use mikktspace in your object’s properties…

Hi there,

I’m having an issue with an FBX file I’m trying to import into my level. When I import it, the normals are flipped, and I can’t seem to find a fix for it. I’ve tried everything suggested to me, including flipping the normals in 3DS Max before exporting, but that doesn’t help me in this situation, since when I try to bake the lighting, the whole object goes black.

Is there any way for me to invert the normals in Unreal? At this rate I feel like I may need to remodel the object since I can’t find a solution that works for me.


Okay, so there are two issues going on there. First off, if your mesh is importing with the normals inverted, there’s a good chance that the scale transforms have not been applied. In Blender, you fix this by pressing Ctrl-A while in Object Mode and then select Scale, and it resets your model’s scale to 1.0 (100%) across all axes. I’m not familiar with 3ds Max, but you’ll want to go through whatever procedure you use to get your scale transforms at 100% across all axes. If you haven’t already, try that and see if it doesn’t eliminate the issue.

If that’s not the issue, and you’re still importing reversed normal meshes that render black, you can fix this by editing the mesh properties in Unreal (Ctrl-E or double click the icon in the content browser). Go under LOD 0 settings and check ‘Recalculate Normals’ and change the Source Lightmap Index from ‘0’ to ‘1.’ That’s worked for me in the past when I’ve had that problem, however, the first option about fixing your scale should solve the problem without requiring you to hack the mesh properties at all.

1 Like

scale transforms have not been applied