FBX import divides socket position by 100

Importing a mesh with Sockets from Blender (with no scaling options set) imports the positions of sockets wrong.

In this case the Z Position is divided by 100.

To report, import the attached FBX with these settings

This is where the two sockets end up

And the original positions in Blender

Hi Anadin,

Did you mean to attach an FBX to this? While you’re at it, can you also attach the blend file? You’ll need to zip them as AnswerHub won’t accept the fbx file format.

Whoops yes I did. Attached both now - apologies

link text

Hi Anadin,

Apologies for the delay in response. It looks like your blender scene is not set to user centimeters. I’d recommend going to your scene settings, switching to metric, then setting the scale to 0.01.

This fixed the socket locations for me, however you’ll need to re-scale your model and re-locate your sockets if you want it to be bigger than 2x3 centimeters.

Hi , sorry abut my late reply now, yes that seems to work, actually seems to work with skeletal now, in my previous tests with 2.75 and 2.76 it had not. I’ll keep working that for now and see how I got - thanks!

No problem! The scale settings in Blender seem to be one of the major headaches when trying to export for UE4, but it can be done!! :slight_smile: