Download

FBX import crashes 4.10

hi people,

i am testing out fbx workflow and am having persisting problems.
the first tests exporting from max caused UE crashes. these were fully rigged models and difficult to troubleshoot so i am trying simpler examples.

i am now testing out simple fbx with 4 morph targets from zbrush.

still getting crashes:

if i turn off morph targets upon import, unreal does not crash.
if the MT are on, UE invariably crashes.

tried exporting with smooth normals and without. same result.

i am using 4.10 mostly until there is 4.11 with VXGI.

am i doing something wrong or is there a bug in the importer?

Check the version of FBX you are using in the export settings, the most recent version seems to be creating a lot of problems. Change it to 2014/15.

Yeah there is a bug in 4.10 the crashes the app when importing animation. It’s one of those if your doing something custom bugs so in our case we have a custom rig where importing animation from MotionBuilder it crashes. In another project everything imports just fine using the Epic rig.

All works fine in 4.11 though

thank you guys very much for the inputs,
@Steve_T: i have used 2014 and other exporters, but same result always.
@FrankieV: its good to know that the import works but i am confused as to how other people are working around the problem. its the most essential of the features, not something esoteric.

anyway, i guess i need to hop on 4.11. hope there is a vxgi branch pending.