Download

FBX Import completely Black aftter Light Build

Hello Unreal Community!

I’m aware that this is one of the more common questions here but I am pretty desperate since I tried everything except creating Light Maps via Blender etc because the model has around 30.000 faces since its an entire house.

My workflow is really simple, I draw the whole thing in Sketchup and export it as FBX afterwards using this Tutorial series: https://www.youtube.com/watch?v=Teou29-iOiA
Everything else works perfectly fine, texture scaling and the like is no problem at all, yet the fact that Static always turns black remains.
My only other option would be to set it to movable but that way I lose a lot of the lighting quality.

Is there anything else I can try with this sort of problem? Does the model have too many faces? Should I cut it into pieces? Group it so it exports as different single models?

Thanks in advance for your advice!
Sorry for my first post being a question here!

If it’s a building then first it needs to be split into a number of meshes. For example I’d start by splitting to separate floor/ceiling/walls meshes.
Then after that, you have to consider how much surface area a mesh has, if it seems like you can’t get enough detail in a lightmap even at a high resolution then you need to split it up further. For walls for example you’d want to split at a corner.
Try to keep the number of objects low (for performance) so don’t split things if you don’t need to. Things that you can combine are things that are in the same area or use the same material. For things like props (chairs, tables, doors) I would just keep those separate.
When you split meshes up also remember that you will have to redo the lightmap UV’s so that they maximize the UV space for the lightmap.
When you import into UE4 make sure to disable the Auto Generate Lightmap UV’s (it’s not a complete automatic solution and it’ll mess things up if you have lightmap UV’s setup already)
Typically the first UV channel is used for your material and the second is used for your lightmap. If it’s set up that way and the Auto Generate Lightmap UV’s option is disabled then it will import correctly with the lightmap UV channel assigned as the correct UV channel to use for your lightmap.

Yep. Single huge meshes always turn out black for me also. I’m just recreating the walls and floors in-engine with BSP geometry the way we did it in the original Quake days. Good times.

Thank you for the indepth answer!

I’ve split up the model completely now and for testing purposes I isolated a single floor piece and imported that with “Auto Generate Lightmap UV’s” on since its basically the same as a cube in Unreal. It had a grey default texture and it still turns up completely black when I import it. When I turn on “Use Two Sided Lighting” it stops being black but it completely breaks instead, lighting things that should be dark and the like. I also checked the UV Channel and since its just a very flat cube, the Lightmap looks clean.

What I noticed though is that when I clip a point light directly into the model of the floor it works. So atleast some progress?

Again, thanks for the help, I checked old topics and youtube tutorials regarding this but the solution is always either set UV Channel to 1 or raise the resolution of the lightmap.

Edit:
The Point light also effects exactly 1 surface on the side of the model.

Are you sure your meshes are facing the right direction?

The issue is caused by:
-Lightmap UV not assigned to the correct channel
or
-Badly made lightmap UV’s (not using the space well, overlapping, outside 0-1 space, etc)
or
-lightmap resolution too low