Fbx from unity to Unreal problem

when i port the fbx from unity to unreal

i dont noe whether its the texture problem or mesh problem, there is a line splitting the arm
any1 can help? thanks

First thing to check would be, have you checked the ‘flip green channel’ in the normal map texture settings?

You haven’t stated what the problem is…

I’m assuming you mean its darker in UE4. In which case, i imagine it’s just the lighting in that particular view.

Have a look at some of the examples and adjust your material accordingly.

i cant tick the flip green channel, n the problem is at the arm

I totally see what you’re talking about now, still in UE4 your green channel in the normal texture must be the opposite from Unity, double click on your normal texture in the content browser to find these settings.

I could only guess that something is up with the UVs from what I can see?

i think its not only the normal problem, the arm mesh vertices too

Yeah it’s a bit weird, have you looked at it in a 3d program?

Also check there’s no UV’s outside the boundaries (inside blender/3ds etc.), I can’t make everything out from the picture.
Just putting it out there that I’m no expert =p

it looks worse in 3ds max, isit because of lod?


Maybe to narrow things down try exporting LOD0 back into UE4.

not lod, tried deleting it

found out the problem, its with the skin, when i remove the skin n reimport, it looks perfectly fine, so now how do i solve this problem?

Unfortunately I’ve never done any character modelling/skinning/rigging etc. so I can’t even try to help with this =