FBX exporter scaling

There’s bug that has been carried over from UDK.
If you export a mesh out of the engine to FBX and import it into 3DS max, it’s XYZ scale is set to 39.37, the three values have to be set back to 100 to match the correct size it should be.
Would be ideal if we didn’t have to do that.

Hey Matt3D -

I am trying to track this problem down for you. Can you tell me in 3DS Max what are your system unit settings? And when you are importing into Max, can you post a screenshot of your import settings.

Thank You

-Eric Ketchum

The system unit settings are set to generic units.


Here’s steps to reproduce the bug with screenshots.

1.Take a mesh from 3ds max and export it out to FBX using the normal settings you should use


2.Import mesh into Unreal, then right click model and export


  1. Reimport FBX into 3ds max, it will be smaller than the original exported version.


Hey Matt3D -

Unreal Units in UE4 are 1uu == 1cm by default. You can affect world scaling with the world properties but it will end up affecting the physics calculations. To solve the issue when you export from 3DS Max, under units uncheck Automatic but change “scene units converted to” to centimeters. It should now import correctly into the engine based on your original size.

-Eric Ketchum

I don’t think we are on the same page here. However I understand this is a very insignificant thing to try and fix, as it’s very unlikely many users need to export models back out of unreal 4.

The bug I am talking about is not with the process of exporting a model from 3ds max and importing into unreal4
Models that I am exporting from 3dsmax have the correct scale when I import them into unreal as I expect them to be according to the unit scaling.

It’s when you then take that model and export back out from unreal 4. My guess to the problem is that Unreal 4’s fbx exporter is what is applying local scaling to the models it’s spits out, that’s why it’s smaller when re-brought into 3dsmax as seen above. It’s been scaled to 39.37% on all 3 axis.
It should be set to 100.

Again this issue is minor, I’ve actually written a maxscript to reset the scaling to 100 in one click. Solving the issue.