Download

FBX export from Blender produces Popping in Animation

All animation using Action Editor and NLA strips looks fine in Blender, but popping appears in Unreal. This is using a spline rig, and I can’t figure out why it keeps happening.

Please help me figure out what I’m doing wrong! I’ll provide the folder that contains the blender file, fbx exports, a blank unreal project, and images of my export and import settings.
You can get it off of my g-drive here: https://drive.google.com/open?id=0B1YzkLAGhfWwQ0ZvYTZnTHVQbFk

I have a spline rig that is composed of a core rig with an ik spline restraint, a bezier curve, a control rig hooked to the curve, and a twist rig. Most of the animation takes places via the control rig to get that nice S curve motion. I have an action with all the keyframes which I push down to both the core rig and the control rig. I then select the core armature (which makes up the skeletal mesh that is imported into Unreal) in object mode and export the fbx.
Once I import into Unreal, the animation pops. A comparison of the Blender animation versus the Unreal animation is in the link.

You mean the little jerk back to the bind pose when the animation loops?

Try this:

  1. Make the animation start at frame 0, not frame 1. The animation exporter likes to start at 0 and if there are no keyframes, the bones could be exported in the bind pose.

The first screenshot shows the offset in Blender’s action editor.

  1. Set your animations to ‘cyclic’ if they loop. To do so, open Blender’s action editor, select the Armature, select your action in the action editor’s dropdown, hover your mouse over the bone list in the Action Editor and press ‘A’, then click Channel/Extrapolation Mode/Make Cyclic.

The second screenshot shows the location of the option in the action editor’s menu.

  1. Use Blender’s graph editor to fix jerky keyframes at the loop point

There are some curves in your animation (see third screenshot) that have big jumps right at the looping point, likely responsible for some of the jumps you see.

Hope this helps!