Download

FBX Camera Animation Import Broken?

Howdy

Trying to import an animated camera from 3DS Max to sequencer, but every time I do no keyframes come in. Is anyone else having this issue? I can’t seem to find a solution.

Not sure that the export is even possible.

you can bypass the issue by creating a skeletal mesh with a single bone, animate the bone, import the skeletal mesh and animation, and bind the camera to the bone.
for that you will probably need to convert the animation to an actor and pop a camera inside it.

Only workaround I can think of atm.

I’ll give that a shot, but why is it not possible? The option is there in the menu. Is it just broken?

I just do not think unreal has any idea what to do with it.
I have seen videos where it works when using Datasmith or similar plugins.

If you import a FBX you usually import a mesh, skeletal or otherwise. They are the only 2 options in the importer…

Are you running “Import…” from the sequencer menu as described here?

https://docs.unrealengine.com/en-US/…ort/index.html

That should create a camera and then import the keyframed animation onto sequencer tracks as keyframes (as opposed to an animation asset). If you’re running that and it’s not working, are there any errors in the Output Log?

I figured out I hadn’t baked my keyframes correctly from Max. My specific use-case is that I’m bringing a motion tracked 3D camera from Max (tracked in Syntheyes) into UE4. My idea behind this is for rendering virtual sets at less than an hour+ per frame :wink:

The issue I’m having now though is that the camera comes in tilted on its side. I fixed this by adding an additional relative rotation track to my camera and properly rotating it -90 on the yaw and -83.523 on the roll. The roll value is copied from the first keyframe of the X rotation in 3DS Max.

I tried variations on exporting with Z-up or Y-up, as well as importing with front X facing, but they seemed to not make a different, except for the front X facing putting the camera way off in the middle of no where.

Further issues:

That fix I mentioned above does not work. The keyframes are now coming in, and the position/rotation values match Max, but the movement of the camera doesn’t, and when I try to composite it with my scene footage, it doesn’t match the camera movement. Performing a render from Max with the exact same camera matches perfectly with the footage.

Finally friggin’ figured it out. Turns out it doesn’t play nicely with Max’s Physical Cameras, and instead a Free Camera should be used.

As far as the Z-up Y-up issue, this depends on the program (max, maya, blender, etc.) some are right hand based, some are left hand based.
UE4 is left handed.
Max is Right handed.

They both have Z up, so the worst thing is that your Y is flipped.
I don’t think this is in any way related to what your issue was, but it’s still worth noting.

Hey Tommy,

This is something I am having issues with. I also have tracked 3d camera and want to import the animation from either 3dmax or fusion. From max I am getting a the camera import ok and I can see a animation path with the keyframes on it. If I click on the keyframes in the 3d viewer, the camera moves to that keyframe. But in the sequencer I dont see any keyframes, and when I play the sequence, the camera does not move.

Did this happen to you and do you know how to fix? The camera in 3dmax is a free camera.

Thanks.
Brendan

UPDATE

Figured it out, 2 mins after I posted. :p;):rolleyes::rolleyes::rolleyes:

The animated camera from Fusion to Max was from frame 7000+
In Max I rescaled time for the animation so that the keyframes all shifted to start at 0, then reimported and it worked great.