FBX Animation import not working anymore

Hi,

I use blender for creating my 3D character and all the animations. Every animation has its own fbx file without the mesh in it, just the armature.

In 4.7 I didn’t have any problem with importing these animation files, but in 4.8 I always get this message:
“Failed to import ‘D:\Desktop\prot1\v5\JackAnims_HalfWall20.fbx’. Failed to create asset ‘/Game/ThirdPersonBP/Character/Animations/Import/HalfWall/JackAnims_HalfWall20’”
and: “Failed to find any bone hierarchy. Try disabling the “Import As Skeletal” option to import as a rigid mesh”

Here is the import dialog in 4.7:

And here in 4.8:

It looks alot different.
Is it one of the new checkboxes that I should check or is this a bug?

Best regards
Joey

Hey dj_joey,

Would you mind sending me your mesh fbx and one of the animations? I have some example assets and one of them is an animation file with bones only. When I decide to import the animation fbx in 4.8, I don’t get the “Import as skeletal” option and my import window looks closer to your screenshot from 4.7.

-Matt W.

Hey Matt,
I’ve sent you the files.
Tell me if you need anything else.

So I’m having some issues with your animation file. I’ve attempted reimporting it into blender just to see what was in the FBX with no success, but then I imported it to Maya and the only content in the FBX file is a bone called Mycharv2 with nothing else happening. There is one key on the bone at frame 1, but nothing else. I’m suspecting there was an issue when you exported the file.

What version of Blender are you on?

-Matt W.

Hmm… Blender 2.73… Yeah reimporting the animation in Blender doesn’t work for me neither.
However I tried importing the files in a new 4.7.6 Project and it worked.
This is how I did:

]

46634-importanimation.png

  • Joey

Hey Joey,

We actually just tracked down this issue. It has been fixed in 4.9 main branch. We are looking at getting it into a 4.8 hotfix though. No promises on that as it hasn’t been integrated into 4.8 latest yet. Depends on if the fix is deemed as too major of a change for a hotfix. The bug is UE-17384.

-Matt W.

Hi Matt,
Cool that you could track down the issue. In the meantime if anyone has this problem, as a workarround the fbx-file can be imported into a 4.7 project and transferred as uasset to the 4.8. project.
-Joey

Hi,
I saw in the 4.8.2 announcement thread that this issue is fixed.
However I still have the same behaviour as with 4.8.1, so I still cannot import animations.
I already posted in the announcement thread but I think it will rather be seen here.
Maybe it was mistakenly not put into the build?
-Joey

Most of the issues with import from Blender were on Blender’s export. Can you tell me what version of Blender you’re using?

I’m currently writing up a revised Blender import forum post, but can’t promise I’ll have it done quickly.

Now 2.75a / Before 2.73 (No change)

Something I may should mention: A problem with blender export is that it adds an empty bone with all root bones connected to it. However this is super not useful because this “root” bone doesn’t move at all which means you cannot use root motion. So the way to solve this is to delete the line of the export script in “export_fbx.py” which does that. This is what I did.

Line of code:

the armature object is written as an empty and all root level bones connect to it

fw(’\n\tConnect: “OO”, “Model::%s”, “Model::%s”’ % (my_bone.fbxName, my_bone.fbxArm.fbxName))

So if I am the only one with this problem this (I) may be the troublemaker which I would be very sorry about for wasting your time.

However I don’t think this is the problem because:

  • importing the fbx without mesh worked in 4.7
  • it works fine if I export the fbx including the mesh and deselect “import mesh” when importing (This is now my solution which I just found out)

I’ve been able to get root motion working, but you have to animate this object in blender:

51248-blenderrootmotionbone.png

That object is what get’s exported as the root.

I apologize if this is known information, but that’s the only way I got root motion working.

ok I didn’t know that… thanks.
However the problem persists. I made a clean blender install and I exported a skeletal mesh and import it in UE4. Then I export an animation without the mesh and import and the import fails.

Send me a screenshot of your export settings from blender for your export without a mesh.

I tried out an “armature only” export and it worked as expected when importing onto an existing skeleton.

Hi Matt,

This are the settings that worked in 4.7
-Joey

Can you try switching from FBX 6.1 ASCII to FBX 7.4 binary and using these settings?

-Matt W.

Hi Matt.
Good news: It worked :slight_smile:
However: I got a message that the “Imported bone transform is different from original”
and the animation looks a little bit different than in Blender…

  • Joey

Can you re-export the original Armature+Mesh with the new settings as well?

Yeah this works. However the imported mesh is about 30 times bigger than normal… And why does it add “bonename_end” bones to every childless bone?

Did you create the mesh in blender or import it? I’m thinking that you had a different setting for “Scale” on import. Either that or your export scale isn’t “1”, but is instead “100” or something else.

I believe the extra bone names are a result of “Add Leaf Bones” being enabled.

It wasn’t directly Blender in the beginning and the export scale was 1.

So I tried the same with a mesh that I made completely myself without another program. It looks like the “add leaf bones” was the reason for the unnecessary bones. However after unchecking this option the animation import doesn’t work anymore just like with ASCII fbx… And the scaling issue persists here to.

By the way binary fbx doesn’t look like it’s an option to me because import and export takes much much longer than ASCII fbx…