"Fatal error: [File:D:\BuildFarm\............

Hi All

Anyone seen this error, and may know a solution. Happens every I load the game in the editor.

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\CoreUObject\Private\UObject.cpp] [Line: 2719]

C++ trial ran out, so no idea what is in line 2719

I believed this happened straight after a when UE4 froze and I had to use CTRL + ALT + DEL to shut it down.

In attached file:




Sorry All



In order to determine the cause of this crash, I’ll need some more information.

  • Have you been able to reproduce this crash in a clean project?
  • What steps can we take to reproduce the issue on our end?
  • Could you please provide the full class(es) (.h and .cpp) where you are using FObjectFinder?


Going on road trip for 2 days, but for now.

  1. I can load other projects without error in 4.9 (This is only project in 4.10), have not tried a clean project yet,

  2. Have no ides.

  3. I do not know how to find them, do I just search for anything ending in .K or .CPP in the project.



I will be marking this topic as resolved for tracking purposes, but when you return from your trip, please leave a comment to re-open the question.

Let me know the results of trying a clean project, and also give the 4.11 Preview a try and see if the issue occurs there as well.

Also, just to clarify, when exactly is this crash occurring? Does it happen when you attempt to open a project?

Thank you


I will install 11 and give that a go.

It happen just as the project should load. 99% then bang, crash.

Go into your project folder and delete your Saved and Intermediate folders. After you’ve done this, attempt to launch the project again.

No such luck deleting those folders, same issue.

Talking to the Main programer, to find those .K and .CPP files.

Do you happen to recall any changes that you may have made before the editor froze and you had to force shut it down?

No, it was sitting in background while I was watching online tv.

Installed 4.11, but needed 2015 Visual, so waiting for a couple of things to finish as I need a system reboot.

Once you have everything installed, let me know the results of your tests. Thank you.


Our C++ coder fix it some how. He just sent me a message on Skype, loaded and it is fine.

Thank you for your help anyhow.


I’m having the same issue, it would great to know how it was resolved.


You got the error in your C++ coding as well?

I got the same ERROR INFO:

fatal error: [File:…UObject.cpp] [Line: 2719]

I fotgot about the middle, anyway it’s a error on the .cpp.

In my situation, my Unreal Engine version is 4.15.

I have a parent class named “ProjectNameObject”

in the ProjectNameObject.h:



    USphereComponent* Collider;


in the ProjectNameObject Constructor of ProjectNameObject.cpp:


    Collider = CreateDefaultSubobject<USphereComponent>(TEXT("Collider"));



then the subclass inheritanted from ProjectNameObject named SubObject.

in the SubObject Constructor of SubObject.cpp:


    Collider = CreateDefaultSubobject<USphereComponent>(TEXT("Collider"));



So here comes a conflict.

Once I delete those two line in the SubObject Constructor of SubObject.cpp. My project load successfully.