Fatal Error Crash when opening Blueprint (log attached)

I have a C++ class and created a Blueprint from it.

Everytime I double click the Blueprint to open it… it crashes.

This is the LOG file taken from \Documents\Unreal Projects\PROJECT_NAME\Saved\Logs

It has ALWAYS worked. I repeat: ALWAYS worked… something must have happened… I don’t know why but now it causes the Engine to crash.

I did nothing, except adding a new Object Channel from the Collision settings and apply that channel as Objec type of my Blueprint class… that’s it.

What’s going on?

I created a new Blueprint (always deriving from the same C++ class) and it runs fine.

But even though I used this workaround I want to know what happened with my old Blueprint… why does it cause my Engine to crash?

I gave you the log file, hoping you will make my ideas clear.

Hey gedamial-

When you mentioned changing object channel, was that done though code or in the blueprint itself? If it was done in code, have you tried reverting the settings and then open the blueprint again?

All is done through the Editor.

I even remade my Blueprint and set the Object channel property. It doesn’t crash.

I don’t know why the old one crashes

The log files provided appear to show an access violation as the cause of the crash. This means that the blueprint was likely trying to refer to something that either did not exist / had not been set yet. If you were able to create a new copy of the blueprint that works then it would be best to just stick with that.

Hey gedamial-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


Doug Wilson