Download

Faking block all collision

Hi, I’m making a third-person game where you walk around a small planet, somewhat similar to super Mario galaxy. I found tutorials on how to make the player walk around the planet. (I’ll add screen shots of these blueprints). For this to work simulate physics is turned off. Now whenever my player runs to their spaceship for example, the block all collision does not work anymore, instead they will just go through the spaceship actor.

So I was wondering if there is any other way of maybe recreating or faking a block all collision.

Overlap collisions work just fine BTW.


I get that simulate physics might make planet movement bad with gravity as well as collision. But couldn’t you keep simulate physics, turn off gravity, and if the planet boundaries cause issues set the static mesh collision to complex?

Hi MrHiguy, thanks for your reply and sorry for coming back to it so late.

Unfortunately it didn’t solve the collision issue.
What did fix it however was enabling the sweep option in the “AddActorLocalOffset” node .
Thought I would post it here, for people who encounter the same problem.